Kotlin: Supertypes of the following classes cannot be resolved.

已回答

I hope this is the right place to ask:

I git clone intellij-community
I open it in IDEA Ultimapte EAP 2023.3
I run the getPlugins.sh
when I build the project I get many Kotlin errors like:

```
Kotlin: Supertypes of the following classes cannot be resolved. Please make sure you have the required dependencies in the classpath:
   class kotlin.coroutines.EmptyCoroutineContext, unresolved supertypes: java.io.Serializable
   class org.jetbrains.annotations.ApiStatus, unresolved supertypes: java.lang.Object
Adding -Xextended-compiler-checks argument might provide additional information.

```

somehow it not find the `java.lang.*` or `java.io.*`

maybe someone can point me where to look?

 

0

ok - solved it by not using the `jbr-17`

downloaded `Jetbrains Runtime` which results in a name: `jbrsdk-17`

I can build the project without the errors while compilation

1

Yes I have gone trough the settings. And I can not see where it breaks.  I can not found where I can update/setup a Kotlin SDK.

 

The Problems Tab is empty

Here are the Setings of jbr-17

 

But at the Kotlin Setup I miss some paths, but I can not change the home path:

 

I am fear to delete the Kotlin Entry, because I can not add a different Kotlin. The “Add” menu item don't list a Kotlin option:

 

 

The Kotlin Plugin is installed:

 

Since there are still so many screenshots - here are more to show the settings:





 

Sorry for the many screenshots - If you need more infos: I am happy to add them :)

0

Side note: I looked also for the `Jetbrains Runtime` at the list from `asdf list all java` but there is no entry there

0

请先登录再写评论。