Ultra slow indexing

I know there are already issues opened on this subject but this needs to be addressed !

From time to times PHPStorm stalls and needs to be restarted. After restart, PHPStorm is spending ages (currently more than 30 minutes ans still far from finished !) indexing files on start, including several minutes (!!) on individual files like php.jar on some .ts files.

I'm using PHPStorm on windows with project files on WSL2. All project and Jetbrains files are excludd from Windows Defender.

- I have tried disabling real time virus protection  : no change

- I have upgraded to latest version 2023.2.4 : no change

- I have tried “invalidate caches” (with default options) : no change

- I have a SSD, plenty ok disk space and RAM and enough CPU power. This is not a hardware problem.

 

0

Hello,

Sadly, this is true and there are still ongoing issues with the performance on WSL shares.

I believe that you have already seen this YouTrack meta-issue ticket:
https://youtrack.jetbrains.com/issue/IDEA-293604/IntelliJ-is-slow-hanging-when-working-with-WSL-filesystem
 

However, I wonder if in your specific case it is not related to the WSL but to the project itself. 
Have you tried to make a local copy of it and check how indexing performs there?

 

0

请先登录再写评论。