Waiting for incomng connection with idekey ....

HI All, 

I have spent the whole day trying to get xdebug to work in PHPSTORM 2023.3 without success. 

I a using MacOS 14 with PHP8.3, Xdebug 3.3, Laravel Valet into Laravel 10. Xdebug is installed into PHP and into Storm.  Valet does not use symlinks so I have not done any path mapping.  Setting up the Host under servers as ‘localhost’ is not the valet way of doing things, alegedly, you put the url as host. see image. 

No matter what I do I can not get Storm to stop on the first line of PHP or any breakpoints. It totally ignores the PHPSTORM bookmarklets from Chrome.  

However, if I do a xdebug refresh (see screen shot) then it stops with ‘waiting for incoming connection …’ 

I have searched through SO, Storm community and extensively used OpenAI all without any success. 

Hope you might have some ideas. 

Many Thanks! 


No matter what I do I can not get Storm to stop on the first line of PHP or any breakpoints. It totally ignores the PHPSTORM bookmarklets from Chrome.

Please do the following:

  1. Configure the Xdebug remote log (it's better to create the file and set 666 permissions on it manually)
  2. Retry a debugging session via the zero-configuration method (that is, don't use any run/debug configurations in PhpStorm)
  3. Share the following data:
    • The Xdebug log
    • A screenshot of Settings | PHP | Debug in PhpStorm
    • phpinfo() output run through Valet, as an HTML file

You can upload it all here: https://uploads.jetbrains.com/browse


Many Thanks for helping out! I was about to submit a support ticket. Are you a Jetbrains employee? 
I tried using zero config debugging last week without any success. 

I have have attempted to upload the requested documents without success. clicking the supplied link takes me to a signin to Google. when I enter my Google credentials I am met with this message: 

“User 'vincej1657@gmail.com' (IP: is not authorized to any of the roles: is not from domain 'jetbrains.com' Make sure to log in with your @jetbrains.com account and turn to #it-team channel in Slack to get access. Reload to log in again.” 

This makes no sense to me as I can obviously login to my Jetbrains account and see my licences, and this comment. 

I could just send you a link off my google account for the php.ini etc. 

any ideas?? Thanks! 


Ok - I see the problem, you added ‘browse’ to the url, which of course I have no authority to browse. 

My upload ID is 2023_12_12_8rAnf82E6yb2bMN28ybF2x


Yep, sorry about that - the /browse link is the one my browser auto-completes for me because I use it constantly, and I forgot to clean it up before sending. I am a JetBrains employee, yes.

In Settings | PHP | Debug, you have Ignore external connections through unregistered server configurations enabled - please disable it, you don't need it for now.

Then, the way the Xdebug log looks means that Xdebug doesn't start at all because it doesn't see any trigger.
Does the Xdebug log look the same way when you are using zero-configuration debugging?
When you use the zero-configuration debug method, you are supposed to activate Xdebug in one of the suggested ways - which one did you choose?


Hi Eugene, Thanks for coming back and helping out. I disabled the ‘Ignore external connections’ as recommended. I deleted the ‘php webpage’ configuration, and I have run zero-debugging and I am now getting something. I also removed the ‘stop at first line of php’ option.  Please see attached upload. 

The Xdebug log has not anything new since last thurs the 10th. I have a suspicion that the xdebug log only registers something if I force a xdebug refresh using a php web page configuration. 




Upload ID: 2023_12_12_MgW42zyLVJs8kZcEdLeRHQ


Hi Eugene - Do you not have any more advice for me? Should I perhaps create a support ticket?


Ok, I have debug working  with zero config debug. Strange, in the past I always used a  ‘php webpage’ configuration. There is hpwever, one remaining mystery. 

Under “Servers” PHPStorm ignores the server I have configured and it automagically creates it's own server.  However this server is unnamed, has no host defined and uses the identical mapping I set out in my server. 

What / why is this happening?? 


This is happening because your web server has an empty value for $_SERVER['SERVER_NAME'].
According to what I see in this pull request, secured Valet websites don't have this issue.