SSH interpreters not showing in Pycharm Professional



I cannot see my remote SSH Python interpreters in the selection menu when inside a project (only WSL and Docker ones are sown). However, when no project is open, the same menu shows all the interpreters, including the SSH ones.


PyCharm 2023.3.2

Build #PY-233.13135.95, built on December 19, 2023

Runtime version: 17.0.9+7-b1087.9 amd64


Are the Remote SSH interpreters associated with a specific project, shown at one specifically? For example, you can  toggle off to show all interpreters


Thank you for the reply Miguel,

No, this is not the case. Moreover, by clicking “add interpreter”, when a project is open, I only see options “On WSL”, “On Docker”, “On Docker Compose”.

Whereas I see all options if no project is open:

(Docker is not available when projects are closed, I assume it's because the Docker plugin is not functioning in that case).


Is the project stored inside WSL? If that's the case this is a known limitation as local and remote interpreter options are not available  unfortunately -


You are right! This is exactly the case. But, to me, this seems to have become an issue only recently. It was for sure working until some months ago! (maybe I was not updating the IDE frequently)

Do you know if it's planned to be fixed anytime soon? 


This is a regression, the feature is available on 2022.2.4 so you can download that version directly here for now as a workaround to work on this project.

In regards to ETA, there has been no news recently unfortunately as the priority is not high for this one.


This is bad to hear. Thank you for identifying the problem and for the workaround! Hope things are gonna change!