Docker Compose management not working

I'm connecting to a Docker host over SSH from PhpStorm.

Docker Compose is working on the host from the command line, with zero issues.

My issue is Compose management from PhpStorm.

 

(in the above screenshot machines have been started from command line on the server, i.e. “docker compose up -d”.

These work from PhpStorm:
1) start and stop individual containers
2) run terminal in container
3) pull down images
4) view network, including inspection

(in this screenshot, I can start the container from [] db, i.e. expand the “db” container. This works)

 

Does not work:
1) Compose: Start / Stop / Down

(in this screenshot, the commands do not work)

 

This is the error message from the console when trying to start all machines:

-f \shared\docker\shared\docker\docker-compose.yaml -p docker start nginx php-80 php-83 db
Preparing Docker SSH environment...
env: ‘’: No such file or directory
`docker-compose` process finished with exit code 127

The remote path is wrong.
I'm not sure why it is being repeated.
The path to the Compose file is:

/shared/docker/docker-compose.yaml

NOT

/shared/docker/shared/docker/docker-compose.yaml

I'm not sure how to fix that.

Also can you please confirm I do not need Docker to be installed on my PC running PhpStorm.

My PC running PhpStorm is Windows 11.

Docker machine is Debian 12 Linux.

I have checked all settings for Docker and I cannot find any clues. I have also read the official documentation for PhpStorm and I still cannot find a way to fix this.
 

0

 At the quick glance, these tickets look distantly similar (Windows client + Docker over SSH + incorrect path):
https://youtrack.jetbrains.com/issue/IDEA-310932/Docker-via-SSH.-Impossible-to-Down-the-compose-app-no-such-file-or-directory
https://youtrack.jetbrains.com/issue/IDEA-331289/IDEA-uses-the-wrong-docker-compose-file-path-for-stopping-it-when-connecting-docker-via-SSH-in-Windows

I would suggest submitting your own YouTrack ticket with attached logs:
https://youtrack.jetbrains.com/newIssue

If you decide to collect logs, it is a good idea to increase log level before reproducing the problem. It is simple, just add the following line to “Help > Diagnostic Tools > Debug Log Settings”:
com.intellij.docker

Afterwards, logs can be collected as usual with the “Help > Collect Logs” menu action.

0

Hello

Yes, it looks very similar to the bug on IntelliJ IDEA.

That bug was posted 5 months ago, but the bug is still open.

Is it even worth me reporting it?

0

Same with #IU-241.14494.240. Does try to start docker-compose via Docker Desktop although it is configured for WSL2…

0

请先登录再写评论。