Webstorm overwrites or merges the lines in the terminal


Hi there,

I have a subscription for Webstorm and I like the product, however the terminal within Webstorm at least on Mac is quite buggy. When I try to use the uparrow to find a command: npx cypress .. uparrow or npx playwright or whatever when using the uparrow, then it looks like its inserting or partially overwriting the commands. 

Maybe it's a setting or something, but it's unusable and quite annoying user experience. How can I fix this?



Please file a bug at https://youtrack.jetbrains.com/newIssue?project=IDEA and attach the logs (Help | Collect Logs and Diagnostic Data).

Also attach the screenshot with the terminal settings (Settings | Tools | Terminal).

Can you still reproduce it with the New Terminal available in https://www.jetbrains.com/webstorm/nextversion/ ?

See if disabling the custom prompt helps.


Updating to the version you recommended, solved the problem. That is interesting, because I tried that a couple of months ago and that did not work. Awesome! Thanks for the help!