WSL Git not working with PHPStorm 2024.1

I upgraded to PHPStorm 2024.1 and it is now telling me that Git is not installed.

I even tried to manually set the path to the Git binary in WSL and it still didn't work.



Apparently, you are experiencing the following issue:

Please try a workaround from this comment:

Just in case, I will quote add it here as well:

- Open built-in IDE registry (Help > Find Action > “Registry”);

- Untick wsl.use.remote.agent.for.launch.processes option;

- Restart the IDE.


That seems to have fixed the problem. 

Thank you!


I had a similar problem.

The first few days it was just really slow and I managed by invalidating the cache (maybe just restarting was enough, who knows now).

But today it was stuck to `updating` under the `local changes` tab and I couldn't use git at all under phpstorm (I usually use it only to check the changes I made, I do everything else in the terminal).

Unticking wsl.use.remote.agent.for.launch.processes solved the problem.