Plugin 'JetBrains AI Assistant' (version '241.15989.156') is not compatible with the current version of the IDE

已回答

I just updated IntelliJ Idea and it's plugins and I started to get this error:

Plugin 'JetBrains AI Assistant' (version '241.15989.156') is not compatible with the current version of the IDE, because it requires build 241.15989.77 or newer but the current build is IU-241.14494.240 Plugin 'Space' (version '241.15989.9') is not compatible with the current version of the IDE, because it requires build 241.15989 or newer but the current build is IU-241.14494.240
0

It looks like your IDE did not update for some reason. Please try to update it again from https://www.jetbrains.com/idea/download/index.html or via https://www.jetbrains.com/toolbox-app/ .

Make sure Help | About displays 2024.1.1 version Build: 241.15989.150.

0

Another possible reason is if you have multiple IDE versions installed side by side (2024.1 and 2024.1.1). Since they share the same Plugins directory: https://www.jetbrains.com/help/idea/directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#plugins-directory , launching an older version after updating plugins with the newer one will cause such a problem. Double check you run the latest version of the IDE.

0

I fixed it by reinstalling the AI plugin using settings>plugins. Which was strange as I just updated it, but after that the update for PyCharm 2024.1.1 became available, after installing en restarting all was well again.

2

On each start, it offers to install plugins and then it fails, you need to go to Settings - Plugins, reinstall them manually, and then restart the IDE, I have uninstalled some of these plugins, because it's become distracting.

0

请先登录再写评论。