Disable doxygen



OK, no answer to my earlier doxygen questions, so how do I go about disabling doxygen in the editor - it's started hiding my doxygen groupings behind //… blocks but I'd rather be able to see them.

Doxygen is not listed in plugins and searching for it in settings doesn't bring up anything.





Hit shift twice, type in code folding (toggle folding), do this while your cursor on the line with …


Weirdly, it's back to showing me ‘formatted docs’ again today.

It's *almost* useful, except a) I'm trying to edit them and don't want to have to hit the little pencil icon and b) It still stuffs up with blocks of conds/groupings. The font is also uncomfortably small for me…

I have a feeling my code folding is already off: “Settings->Editor->General->Code Folding->Documentation comments” is unchecked anyway.

Is there no way I can opt out of doxygen altogether?

OK, found the problem. The "
“Settings->Editor->General->Appearance->Render documentation comments” appears to be being ignored sometimes.

It was turned off so I turned it back on, went back to my .h file and it's still showing formatted docs, went back into the option and turned it off again - as it had been in the first place - went back to the editor and the doc formatting is finally off again.

I suspect the same thing is happening with the docs code folding.

I will open a bug report.