Reproducing compatibility problem in 2024.2

已计划

I got a compatiblity error report from the plugin verifier on my plugin marketplace page. I want to reproduce the problem by running the plugin verifier on my laptop, but it can't download the latest version that's complaining about compatibility.

Here's the compatibility error I received:

IntelliJ IDEA Ultimate 2024.2 eap (242.12881.66)4 compatibility problems. 1 usage of deprecated API. 6 usages of experimental API (Restart)
4 compatibility problems
Live Coding in Python 4.11.4 is binary incompatible with IntelliJ IDEA Ultimate IU-242.12881.66 due to the following problems
Class not found (4 problems)
Access to unresolved class PythonCommandLineState (3 problems)
Method LiveCodingAnalyst.start(Project, DataContext) references an unresolved class PythonCommandLineState. This can lead to NoSuchClassError exception at runtime.
Field LiveCodingAnalyst.commandLineState references an unresolved class PythonCommandLineState. This can lead to NoSuchClassError exception at runtime.
Method LiveCodingAnalyst.lambda$startProcess$8() references an unresolved class PythonCommandLineState. This can lead to NoSuchClassError exception at runtime.
Access to unresolved class PythonRunConfiguration (1 problem)
Method LiveCodingAnalyst.start(Project, DataContext) references an unresolved class PythonRunConfiguration. This can lead to NoSuchClassError exception at runtime.

I updated my build.gradle.kts sections to reference the 2024.2 version that's complaining:

intellij {
    version.set("242.12881.66")
    type.set("IC") // Target IDE Platform: IU for Ultimate, IC for community

    // Pythonid for Ultimate, PythonCore for community
    plugins.set(listOf("PythonCore:242.12881.66"))
}
// ...
    runPluginVerifier {
        // Verify against sinceBuild version and current version.
        ideVersions.set(listOf<String>("233.11799.241", "242.12881.66"))
    }

When I run the plugin verifier or the IDE, I get the same error complaining that it can't find the version:

8:40:36 a.m.: Executing 'runPluginVerifier'...

[gradle-intellij-plugin :] Error when resolving dependency: DefaultExternalModuleDependency{group='com.jetbrains.intellij.idea', name='ideaIC', version='242.12881.66', configuration='default'}
org.gradle.api.internal.artifacts.ivyservice.DefaultLenientConfiguration$ArtifactResolveException: Could not resolve all files for configuration ':detachedConfiguration1'.
	at org.gradle.api.internal.artifacts.configurations.DefaultConfiguration.rethrowFailure(DefaultConfiguration.java:1524)
[SNIP]
	at org.gradle.launcher.daemon.server.exec.StartBuildOrRespondWithBusy$1.run(StartBuildOrRespondWithBusy.java:52)
	at org.gradle.launcher.daemon.server.DaemonStateCoordinator$1.run(DaemonStateCoordinator.java:297)
	at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:64)
	at org.gradle.internal.concurrent.ManagedExecutorImpl$1.run(ManagedExecutorImpl.java:48)
Caused by: org.gradle.internal.resolve.ModuleVersionNotFoundException: Could not find com.jetbrains.intellij.idea:ideaIC:242.12881.66.
Searched in the following locations:
  - https://cache-redirector.jetbrains.com/www.jetbrains.com/intellij-repository/releases/com/jetbrains/intellij/idea/ideaIC/242.12881.66/ideaIC-242.12881.66.pom
  - https://repo.maven.apache.org/maven2/com/jetbrains/intellij/idea/ideaIC/242.12881.66/ideaIC-242.12881.66.pom
Required by:
    project :

FAILURE: Build failed with an exception.

* What went wrong:
Could not determine the dependencies of task ':prepareSandbox'.
> Failed to query the value of task ':prepareSandbox' property 'librariesToIgnore'.
   > Could not resolve all files for configuration ':detachedConfiguration1'.
      > Could not find com.jetbrains.intellij.idea:ideaIC:242.12881.66.
        Searched in the following locations:
          - https://cache-redirector.jetbrains.com/www.jetbrains.com/intellij-repository/releases/com/jetbrains/intellij/idea/ideaIC/242.12881.66/ideaIC-242.12881.66.pom
          - https://repo.maven.apache.org/maven2/com/jetbrains/intellij/idea/ideaIC/242.12881.66/ideaIC-242.12881.66.pom
        Required by:
            project :

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 1s
8:40:38 a.m.: Execution finished 'runPluginVerifier'.

How can I test with the latest version?

0

I tried again today, and it now reproduces the compatibility problem report. I guess the plugin verifier is a few days behind the one that runs on the plugin marketplace. Is the release schedule published anywhere so I can see whether a version is out yet?

Any advice on how to deal with these incompatibility reports?

0

Five minutes later, and it stopped working again. What's going on? I see the same error message as before.

0

请先登录再写评论。