Android Studio plugin "Menu Item" is not visible in the Jellyfish Android studio IDE.


We have a stable SDK developed for support android developers. Through plugin.xml we positioned it in the Main menu as shown in the 1st attachment. It worked without any issue till Iguana release in Android studio. But with the latest release called Jellyfish it is not showing in the main menu.

It was identified in the engineering validation conducted before the next plugin release version. After finding that tried to fix it through our plugin.xml. Original plugin.xml (With test attribute) with actions also attached here. (Upload id: 2024_06_03_23sRp4rgvHXWfYDZARdPcw (file: plugin.xml))
Some changes done to check the issue listed below,
Changed  <idea-version since-build="223" /> .
Changed actions to be visible inside EditMenu. Then they were visible inside relevant Menu.
But if we type TEST(Not real) in the search everywhere textbox this menus are visible, when click them plugin behaves normally without any malfunction. Kindly hope your response.



Please try adding popup="true" to the action group. In general, adding new top-level items to the menu should be avoided. Please try adding them to existing top-level menus instead.


Hi Yann,

Thanks for the support ! It worked well.