No autocompletion for SET type in MySQL Database


Is there a way to use auto-completion for SET types in MySQL like there is for ENUMs? Because as soon as I use the autocomplete I can see and select my options from a dropdown, but I can't select multiple options or select another option after the , to separate.

Table Setup:

Autocompletion after selecting an option:

Or is there even a way like in Navicat to use checkboxes for a SET ?

Kind regards



Do you mean that executing autocomplete after the comma doesn't work? Suggestions are shown fine on my side.


Jeha, i won't get any suggestions on a SET after i selected the first option via autocomplete. After i added the comma, it shows no suggestions


Have you tried to explicitly open code completion via shortcut (Ctrl+Space by default)?


Yeah didnt changed any settings and tried it that way. I can do a video of this if it is needed. Also i tried it on a fresh Installation which also didnt worked


Please attach information from “Help | About” (click on Copy and paste data here) as it seems to be working fine on my side.


DataGrip 2024.1.3
Build #DB-241.17011.41, built on May 15, 2024
Licensed to **********
Subscription is active until December 16, 2024.
For educational use only.
Runtime version: 17.0.11+1-b1207.23 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 11.0
GC: G1 Young Generation, G1 Old Generation
Memory: 4096M
Cores: 20
Non-Bundled Plugins: (241.17011.2)
 com.mallowigi (96.0.0)
 com.chrisrm.idea.MaterialThemeUI (9.2.1)


Please try to temporarily disable custom plugins ("Settings | Plugins - Cog wheel - Disable all downloaded plugins"). Will it help?


I disabled all downloaded plugins, but nothing changed. But i have noticed something, which might be the fail in this case.
I've used it like “option1,[TRIED TO OPEN AUTOCOMPLETE]” ← It didn't worked, because of the missing space after the comma.
As soon as i tried like this “option1, [TRIED TO OPEN AUTOCOMPLETE]” ← It worked.

Because my options from navicate (which i used previously) are show like “option1,option2,option3”…. So i never thought about a space after the comma. So i think my problem is “fixed”. Just a layer 10 problem :)

But is there any method to use a set with checkboxes to select all wanted options instead of looking for them via autocomplete?

Thanks for the update.

Do you mean that you want to control the auto completion by reducing the amount of matches from the drop-down? Or do you want to view the syntax documentation while you type your statement?