PyCharm debugger not displaying variables and hanging when resuming program


Details: I am experiencing an issue with PyCharm's debugger. I am running PyCharm on macOS M2 and have tried reinstalling it, but the issue persists. The problem occurs when I run any integration test pipeline in debugging mode; the code stops at the first breakpoint, but I am unable to see any variables. Additionally, if there are any collection objects in scope at the time the breakpoint is hit, the debugger says "Collecting data..." instead of showing me the value of the variable. When I try to resume the program, it shows "continue" but hangs there.

My PyCharm version is pycharm-community-2023.3.5, and the Python version I am using is 3.8


Please try to create a new project on the latest 2024.1.3 PyCharm version and let me know in case the issue persists. If it does, provide the code sample so we can try to reproduce it from our side.


I'm having this exact same issue. I'm going to try recreating my conda environment. This is the first time I've seen this problem with PyCharm. I made sure to toggle the `Gevent compatible` flag on but this didn't make a difference.


I created a new environment on a fresh node and the problem went away. Same process. Very weird!

Is there a way to purge all files Pycharm has on a specific remote machine? My guess is something was sticking around and gumming things up…


Hi Rylanschaeffer

Is there a way to purge all files Pycharm has on a specific remote machine?

Aside from venv directory PyCharm stores helpers for SSH interpreters under ~/.pycharm_helpers. You can try to clean up this directory as well.