Loading Database Drivers List forever


I am having a serious issue with the EAP in 2016.3 that causes IDE instability, the IDE sometimes gets into a state where it launches an ever-growing number of "loading database driver" tasks. When it gets to around 500 or so the IDE becomes unusable to the point of needing to kill it.

I noticed this issue a month ago and filed an IDEA YouTrack ticket, which was quickly moved to DBE as https://youtrack.jetbrains.com/issue/DBE-3214. It was soon marked as fixed with no comment and a fix version of 163.5636. I've tested every EAP release since then and can reproduce it on every version up to and including the current 163.6957.12.

When the issue was still not fixed, I created a new IDEA ticket which was relocated again to https://youtrack.jetbrains.com/issue/DBE-3325, thinking maybe the issue is fixed in data grip but needs to be moved into IDEA. Again the ticket was quickly marked as fixed with no comment and now 2 EAP releases since the ticket was marked fixed, there is still no resolution on the issue.

I don't understand why the issue is marked as fixed and no change seems to have occurred with absolutely no comments or discussion about an issue which can cause IDE to eventually crash. It does seem to occur less often and not grow as quickly, but I had 17 "Loading Database Drivers" tasks running this morning right after upgrade to 163.6957.12, but I don't know if it was an improvement or just luck that I haven't triggered the main issue yet.


Hello Jason,

The https://youtrack.jetbrains.com/issue/DBE-3325 issue has been fixed, but the fix is not yet available in 2016.3.X builds. I've asked the responsible developer to clarify in DBE-3325 issue or here in which exact version we can expect the fix.


Thanks for following up. It was DBE-3214 that was originally fixed. Since the fixed in build is less than 163.6957.12, I figured it was in the EAP. It would have been be nice to communicate that the fix isn't actually in IDEA despite the version number, since the ticket was originally filed against IDEA. I noticed that DBE-3214 wasn't in any of the EAP changelogs.