Quick Documentation Lookup not working for Java classes

So, I originally posted this question in the general forum:

I'm  running into the same problem and it's driving me crazy. Documentation  appears on some items but not otheres. For example documenation appears  on Thread and setColor, but not JFrame or setPreferredSize.

I've tried  everything. I've added this:


Both  as a library to the module's project settings via "Attach  Documentation", I've added its subdirectory of docs/api. I've added this  to the Documentation Paths of the SDK under Platform Settings. I've  added the URL http://java.sun.com/j2se/6/docs/api to all these places.

Nothing works. :-\

Using 9.0.2 CE.

Now I think it's a La Clojure issue, because the docs appear just fine in a .java file. I've tried putting an (import javax.swing.JFrame) call at the top of the .clj file, but that doesn't seem to help, it still says "No documentation found" when I try to bring it up on the word JFrame in the source.

However, it *does* work if I use on the fully qualified name of javax.swing.JFrame. So is it possible to get it to work somehow on the unqualified name?