Is quick documentation popup working with Scaladoc?

Hey,
I am unable to see documentation in quick documentation popup.
I even attached sources to play 2.3.4 and I am able to see source code with all the docs, but Idea still shows nothing in quick doc popup.

Is it not working or do I miss something?

Idea 14.1.4
Scala plugin 1.5.2

Thanks,
Leszek

评论操作 固定链接

Could you provide idea log please?

0
评论操作 固定链接

Sure, added.
Sorry for the delay. I did not receive notification about your reply.



Attachment(s):
idea.log.zip
0
评论操作 固定链接

Checked IDEA 15 EAP, does not work too.

Screen Shot 2015-08-18 at 12.37.57.png

0
评论操作 固定链接

Sorry, I missed the forum notification

Looks like log doesn't contain anything related. Do you have the issue in a one particular project or in all projects? Is it sbt project(s)? Does the issue appear only in source code of libraries or in project source code as well?

0
评论操作 固定链接

They are SBT projects. Quick Doc does not work at all including libs and my code.

0
评论操作 固定链接

Does it work when invoked with caret at the comment itself? (like http://puu.sh/jFHxK/7fcfdcac85.png )

0
评论操作 固定链接

No, but I am even unable to open popup.
Additionaly, I get an error (15 EAP) for both cases (popup from method name and from comment):

file=ScalaFile:indexMember.scala.html; tree=Element(SCALA_DATA)

I reported that erorr multiple times e.g. error report 906984

0
评论操作 固定链接

Is your project open-source?

0
评论操作 固定链接

Nope. It's big multimodule SBT project, sbt 0.13.5, Scala 2.11.5

I created also new sbt project and it works well.
I checked also mine https://github.com/leszekgruchala/scala-fast-track and works too.

So it must be something related to my project only.

0
评论操作 固定链接

According to the error you mentioned, the issue might be related to bad index, I have such reports, but I can't reproduce index problem for now. Also you said you had checked idea 15 eap, is it the latest eap (142.3926) ?

0
评论操作 固定链接

Yes, it's 142.3926.4. But the problem exists in that project also on 14.1.4.

How can I send you more information?
How can I rebuild index? (Invalidate caches?)

When I started IDEA 15 at first time, everything was indexed from scratch.

0
评论操作 固定链接

I am also seeing this issue in 14.1.4 with scala 2.10.5 and sbt 0.13.9. Unfortunately, I cannot share my project either, only show evidence and try to answer any questions you have. My intellij log shows nothing when I show quick docs. When I look in the project structure, it has correctly pulled in the sources and javadocs for all my dependencies. Even classes and methods in my own project that I have commented do not show any documentation when I show quick docs where those resources are used.

Screen Shot 2015-08-19 at 1.52.30 PM.png

0
评论操作 固定链接

The issue is in the plugin, so I beleive invalidating caches won't help. I will add some stuff for diagnostics, but it won't get to the plugin until next EAP (i.e. tuesday)

0
评论操作 固定链接

FYI The problem remains with Scala plugin 1.8.0 and EAP build 142.4083.2.

0
评论操作 固定链接

The eap is delayed because of the idea platform eap (they are released at the same time). It will be released tonight or tomorrow morning. To enable logging please add following to the bin/log.xml in IDEA install dir (under log4j:configuration root) :

  <category name="#org.jetbrains.plugins.scala.editor.documentationProvider">

      <priority value="DEBUG"/>

  </category>

    <category name="#com.intellij.lang.documentation">

           <priority value="DEBUG"/>

  </category>

    <category name="#com.intellij.codeInsight.documentation">

            <priority value="DEBUG"/>

  </category>

0
评论操作 固定链接

Sorry for the delay, but I was on vacation :)

Log attached.

Scala plugin 1.8.2
Idea 142.4245.2



Attachment(s):
idea.log.zip
0
评论操作 固定链接

Late question, but I'd better ask anyway - don't you have this setting enabled? http://puu.sh/jVe5Y/e2ac74dc3e.png

0
评论操作 固定链接

This was a setting I did not know about...my documentation now shows up!

0
评论操作 固定链接

Yes, stupid me. Sorry for losing your time.

But I have a suggestion. I thought this setting disables validation of the comment, not its generation.

0
评论操作 固定链接

I just discovered this thread after posting what I think is the same issue (?) in the main 'IDEA users' section (sorry - it almost certainly should have been here).  My case occurs with a basic Hello-world illustration which requires no complex project.  I also see a null ref execption in the log which looks relevant.  See https://devnet.jetbrains.com/message/5557945#5557945

0
评论操作 固定链接

@Dmitry - Can you name this setting?  The image link you posted no longer works.

0
评论操作 固定链接

@Jason - the setting is named "Disable parsing of documentation comments".It must be turned off.

 

0

请先登录再写评论。