scalac: Cannot connect to compile server at localhost/127.0.0.1:3200

I used IDEA 14.1.4 with scala plugin 1.5.2 to build a program, and got the warning as follows.


Warning:scalac: Cannot connect to compile server at localhost/127.0.0.1:3200
Trying to compile without it


Is there any one who konws how to solve this issue?

评论操作 固定链接

Hi, we fixed this problem trying to find a free port automatically, but apparently something still can go wrong.

There is an icon for scala compile server in the bottom right corner of the window (see screenshot).
Is it enabled? Can you run compile server from it before make? Does it show the same port number (3200)?

You can also try to set port number manually. Go to <config>/options/scala.xml and set any free port number for the option COMPILE_SERVER_PORT.
If you don't know where the <config> directory is, check this link:
https://intellij-support.jetbrains.com/hc/en-us/articles/206827437-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs



Attachment(s):
compileServerIcon.jpg
2
评论操作 固定链接

Thanks a lot! The problem has been solved successfully.

0
评论操作 固定链接

Did not work for me.

followed the advice, changed the port number a number of times, but that did not remove the warning.
I also tried to tick/un-tick the "Use external compile server for scala", still get the warning.
I tried with "Run" the compiler server, and without it, still get the warning.
I tried re-starting Idea 15 a few times, no change.

Something is not quite right somewhere.

0
评论操作 固定链接

Do you have the same port number in the warning and in the scala.xml file?

0
评论操作 固定链接

yes, my number is 52069. I changed the scala.xml file: tried 52068, 52067, 53069
these are the same numbers that are displayed by the warning

0
评论操作 固定链接

I have the same issue and changing port number doesn't have any effect.

IntelliJ IDEA 2017.1
Build #IU-171.3780.107, built on March 22, 2017
JRE: 1.8.0_112-release-736-b13 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

0
评论操作 固定链接

I have the same problem with IntelliJ 2017.1 (on Windows) and 2017.2 (on Linux).

0
评论操作 固定链接

I managed to fix this for my case as Nickolay mentioned. Updated your config/options/scala.xml to match what IntelliJ reports as the server number in this image

http://imgur.com/uWVT5I8

0
评论操作 固定链接

This is still an issue in IntelliJ 2017.3.3. Setting the port manually only works for some time since it randomly selects another port from time to time...

0
评论操作 固定链接

I'm experiencing the same issue in InteeliJ IDEA Ultimate 2019.1.2 (Build #IU-191.7141.44, built on May 7, 2019)

0
评论操作 固定链接

I have this issue with:

IntelliJ IDEA 2019.3.1 (Community Edition)
Build #IC-193.5662.53, built on December 18, 2019
Runtime version: 11.0.5+10-b520.17 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.6
GC: ParNew, ConcurrentMarkSweep
Memory: 2014M
Cores: 4
Registry: debugger.watches.in.variables=false
Non-Bundled Plugins: VisualVMLauncher, org.intellij.scala, org.jetbrains.plugins.hocon

0
评论操作 固定链接

The issue was resolved when I stopped using the "Setting repository"

0
评论操作 固定链接

I experienced this problem.
Because I'm using the "Setting repository", there's no <config>/options/scala.xml file on my computer.

The solution was to find the COMPILE_SERVER_PORT variable in my Github repo and to commit a change of its value.

2
评论操作 固定链接

 

Inside Scala Compiler Server, I just removed the VM options and apply the setting and it worked for me.

0

请先登录再写评论。