upgrade to 7941 leads to acegi error

Hi - I upgraded idea to 7941. Also updated the jetgroovy plugin.

This has resulted in the grails (1.0.3) acegi plugin throwing an error. I did download the spring libraries (2.0.7) when I setup the project. 'grails run-app' outside of idea works, so I can only figure that my classpath is referencing different spring.

Any ideas?

The error message is:

spring.GrailsWebApplicationContext Bean factory for application context : org.springframework.beans.factory.support.DefaultListableBeanFactory@98f6c7
association.Association Unsupported algorithm: HmacSHA1, size: 160
java.security.NoSuchAlgorithmException: HmacSHA1 KeyGenerator not available


Confirm this as well. Something funky is going on with this one.


I'm not using Acegi but I'm also getting a java.security.NoSuchAlgorithmException on my project when I run inside IDEA 7.0.4 and JetGroovy 1.6.18593. I can run without a problem from the command line, and also on another machine that still has IDEA 7.0.3. Here's the error that I see:

java.security.NoSuchAlgorithmException: class configured for TrustManagerFactory: com.sun.net.ssl.internal.ssl.TrustManagerFactoryImpl$PKIXFactory not a TrustManagerFactory
at sun.security.jca.GetInstance.checkSuperClass(GetInstance.java:242)
at sun.security.jca.GetInstance.getInstance(GetInstance.java:221)
at sun.security.jca.GetInstance.getInstance(GetInstance.java:147)
at javax.net.ssl.TrustManagerFactory.getInstance(TrustManagerFactory.java:120)
at com.agilemark.PayPalSoapPortBeanFactory.getTrustManagers(PayPalSoapPortBeanFactory.java:164)

The exception is thrown when trying to use the default algorithm:
String alg = TrustManagerFactory.getDefaultAlgorithm();
TrustManagerFactory fac = TrustManagerFactory.getInstance(alg); // throws exception


I just reverted to 7.0.3 and 1.5.17497 and my problem went away. If I've made a mistake in configuring 7.0.4 I don't know what it might be.



I am getting the same error, but it didn't start happening until I upgraded to JetGroovy 1.6.18593.


I didn't get it until I moved all my classes into packages, maybe its just a coincidence.


Hello all.

Yes, there was such error. It appeared because after last changes some libraries from user's JRE got to grails application classpath. This bug will be fixed in next build (apparently today's evening) in plugin version 1.6 and 2.0. Sorry for inconvenience.


Edited by: Ilya Sergey on Aug 28, 2008 9:21 PM


1.6.18808 has fixed the problem I was having. Thanks!


i still have this very annoying problem with intellij!

have the newest ide and plugin but receive:

java.security.NoSuchAlgorithmException: HmacSHA1 KeyGenerator not available

when i execute my grails application.


Are you using 7.0 or the 8.0 M1 early release? The release date that I see in the Plugin manager for 8.0 shows August 15 for JetGroovy, so it hasn't yet been updated for 8.0 and still has this problem. As far as I can tell the fix is released only for 7.0.

Edited by: Brad Whitaker on Sep 14, 2008 9:04 PM