[ANN] IntelliJad 0.3

New changes:
- Classes decompiled to memory can now be debugged.
- Line number comments have been shifted to the right of the code using the // syntax to make reading easier
- Decompiled sources can no longer be edited
- If the path to the Jad executable are not present, or to-file decompilation is required but no output path is specified, a popup message is displayed.

There remains an inconsistency between having source code you can debug into, and having source code that is formatted according to your preferred style. Because the decompiled source lacks comments, the output is generally butt-ugly.

Note: The source re-jiggling is currently done with code based on the similar function in IdeaJad - it's good enough for now, but at some point it would be nice to do using the Psi API.

评论操作 固定链接

I noticed a problem in the decompiled version of the class
C:\Program Files\JetBrains\IntelliJ IDEA 6.0\lib\j2ee.jar!\javax\activation\FileDataSource.class

It looks like this:

As you can see, "// 69" is printed twise and causes the rest of the expression to be commented out. The plugin should make sure that the line number comments are the last thing on the line.

0
评论操作 固定链接

Otherwise, good work on getting the line numbers to match! Next we'll just need a bit better code formatting (indents are messed up right now).

0
评论操作 固定链接

Well spotted - i'll look into this tomorrow!

0
评论操作 固定链接

Any chance of a 7.0 version?

0
评论操作 固定链接

It'll be released sometime this week - not sure if I can get compatibility between the 6.0 and 7.0 versions due to changes in the openapi.

0
评论操作 固定链接

That would probably be a good move; I may be wrong, but I'd imagine the
majority of the users of this forum use Idea 7, so that version would be
where you'd get the most feedback.

N.

Steve Chaloner wrote:

It'll be released sometime this week - not sure if I can get compatibility between the 6.0 and 7.0 versions due to changes in the openapi.

0
评论操作 固定链接

That would probably be a good move; I may be wrong, but I'd imagine
the
majority of the users of this forum use Idea 7, so that version would
be
where you'd get the most feedback.


+1 for a 7.0 version.


0
评论操作 固定链接

+1

"Taras Tielkes" <taras.tielkes@gmail.com> wrote in message
news:ae766d0455648c9ccc027649148@news.jetbrains.com...
>
>> That would probably be a good move; I may be wrong, but I'd imagine
>> the
>> majority of the users of this forum use Idea 7, so that version would
>> be
>> where you'd get the most feedback.
>

+1 for a 7.0 version.

>



0
评论操作 固定链接

From v0.4 onwards IntelliJad will only be compatible with IDEA 7. Bugfixes and, where possible, new features for v0.3 will be placed into the 0.3.x version group.

Any objections or preferred approaches to this? If none are raised, expect to see v0.4 sometime this evening.

0

请先登录再写评论。