GenerateToString exception on Selena - need stacktrace

It generated exceptions every time I tried to use it. I lost the stacktrace before I was able to post it.


Norris. Thanks for noticing. Myself are only on 6.04

I haven't tried the new EAP build yet. I'll check it out in the weekend if I get the time (if wife away ;))



I don't have count how many times JetBrains have broken plugins in their IDEA versions.

I ain't easy being a plugin developer for their IDE. I have posted on the openapi forum for help to open up the API to include the member chooser dialog that exists in the older builds:

This dialog is essential for this plugin and I can't do anything about it before Jetbrains decide to include it again.

If not it could be the end-of-line of this plugin.


From the initial look at how the plugin source compiles in the new EAP builds it looks like there are several refactorings in the IDEA core that now makes the plugin source hard to fix.

Looks like JetBrains is on a new path with the Psi moving to somekind of codeInsight package using generics.

At current time I don't have the motivation to fight and adjust to source to work in EAP builds and then see it breaks in a never build.

Maybe when the EAP is near the final I'll get back to it.

Also I had enough hazzle keeping several version in flight to support IDEA 4.x, 4.5 and 5.0 at the same time.