Problem on unitTest installation

I am using IDEA build 1179, jsdk1.4.2, and I have just installed the unitTest0.26.1 via plugin manager. I have also put all the jar files under IDEA_DIR\system\plugins directory.
But when I tried to do configuration under settings\project settings\Junit, there is not any effect after clicking "OK". There is also no any effect when clicking CtrlShiftT (there is such an item in the context menu).

what is wrong with my installation? anyone can give me some help? Thanks!

评论操作 固定链接

sorry, please forget about my "problem" above. I dont' know when I created unused directory called "IntelliJ-IDEA-4.0"...

0
评论操作 固定链接

Hi, it is a problem!
now I have deleted the wrong directory, and go to the correct IDEA installation directory. I found that "unitTest" (with the jar files) has been installed into the "plugins" directory via the Plugin Manager. But the unitTest doesn't work on my IDEA.

your help is appreciated!

0
评论操作 固定链接

0.26.1 works under Pallada but not under 4.0.x. Not sure why.

If you can find 0.25 that one does work under 4.0.x

Jason

0
评论操作 固定链接

Jason is right.
0.26.1 is just for the version for 4.1 (or 4.5 now it seems)
Like I said in my announcement I created another plugin for the pallada/4.1/4.5 version. You have to download the old version which is under unitTest

unitTest -> Aurora 4.0
unitTest for IDEA 4.0 -> Pallada 4.5

Jason, the reason it is that way is the not-backward compatibility of IDEA opened api between 4.0 and 4.1 and the fact that Pallada will be released in just 2 or 3 weeks. I'd rather work on new features than to back port the plugin. In addition 0.26.1 is funtionally identical to 0.25. I am working however on some nice features that I don't intend on supporting in the 4.0 version (See for more details http://www.intellij.net/forums/thread.jsp?forum=18&thread=91849&tstart=0&trange=100#3324851 )

Jacques

0
评论操作 固定链接

Jacques,

I did notice that there were two versions. My confusion on why 0.26.1 didn't work in 4.0.x is that when downloading the normal "unit test" plug in I was actually getting 0.26.1 last Friday and Saturday and obviously it was not working.

I ended up downloading 4.1 in order to get it to work as I could not find a .25 binary.

Jason

0
评论操作 固定链接

where can I get 4.1? I only see 4.0.3 available.
anyway, I am going to wait for release 4.5 before plugin unitTest....

0
评论操作 固定链接

Where can one get the .25 version? The plugin manager in 4.0.3 downloads the .26.1 version for both listed "unitTest" plugins.

0
评论操作 固定链接

There is a bug in the plugin manager: you can create different plugins with the same name. When I later created the unitTest plugin for 4.1 it overwrote the 4.0 one.

It should be corrected now. However use the plugin named "unitTest for 4.0". Sorry for the name confusion.
I wrote to the admin of the plugin site to clean up this mess and normalize the name, so it might change ;)

You might want to vote for the following request to get resolved.
http://www.intellij.net/tracker/idea/viewSCR?publicId=29204
http://www.intellij.net/tracker/idea/viewSCR?publicId=33650

0

请先登录再写评论。