Can't type in editor window



I'm running the latest EAP (142.2887.3) on OS X and I've lost all keyboard input within the Editor and Project windows.

When I type, nothing is changed in the editor windows.  IntelliJ hasn't hung, its just mot accepting any keyboard input.

The problem goes away when I open the Preferences window and type in the search box at the top left.  It's as though this can get my cursor focus but the main editor window can't.

I've only seen this once on the latest EAP and can't replicate it.

Has anyone else seen this problem?



Thanks, @S165235

It's working now.


Its funny people keep assuming the VIM Plugin is even installed and refers to this solution when the reporter (David) clearly stated he hadn't this plugin installed.


It's also interesting that, after three years, people are still having this issues and the only solutions (depending on the configuration) is to disable a plugin which might be needed or to fiddle with the Java runtime which not everyone feels or know how to do.


JetBrains, it might be time to have the issue fixed from your side instead of relying on workarounds which don't even always work.


I have this issue and i don't have the plugin vim.

I'm using Ubuntu 18.04, and 17.10 and this is so frustrating.

Randomly it stops to accept keyboard commands, to "fix" i have to close and open again.




@Serge Baranov, reproduced with 2018.1.3

I will create report as you asked


Why does this need VIM mode, thats an overkill.

And why cant it be 'intelligent' enough to tell us when something is missing instead of dumbly doing NOTHING !


I'm having the same issue on version 2018.1.6, the only thing that will fix is restarting but it isn't only this the problem, sometimes the code suggestion and tasks like grunt or gulp watch stops working. And i don't have VIM plugin installed.


Could you please collect logs and attach them to


PyCharm Professional 2018.1.4 on Mac OS X 10.13.6 - nothing worked, had to shut down pycharm and relaunch.


 @Jaroslaw Zgoda, if you get same issue as I do - try to create new file and then close creation alert. You will get cursor back.


Please try 2018.2 version.


Pycharm 2018.2 has the problem. On ubuntu 18.04, all up to date.


@BrixSat Could you please provide idea.log after reproducing a problem.


Please provide an email to send the log. Thanks


Rubymine 2018.2. It is back again. I need to restart the IDE several times a day. 


It happens to me sevaral times a day on Rider 2018.2.3, running on ubuntu 18.04.


@Ali Firat Karaoglu, @Clement Lavolle can you describe when does the issue occur for you? Is it the same as was initially reported: ? Thanks.


This happens to me on macOS.
When I hold down a letter key that has variants like 'a' macos gives you options so you could write 'á' for example.
This then breaks the writing in WebStorm. Currently I can fix this by swapping my keyboard input source which I have bound to a keyboard shortcut.


In MacOS this happens when character accent is enabled and triggered. If you do not use character accent type this in terminal and it will stop happening

defaults write -g ApplePressAndHoldEnabled -bool false

Happening to me now. I can type where there is already code, but I can't change anything. Nor can I add new code. Tried everything on these pages, and nothing works for me.

Linux Mint 19 Tara.

This is the error in the log file. I have uninstalled Kotlin. Doesn't help. *sigh* Back to Eclipse it is then, until this is sorted out.

OS is Cinnamon 

2018-12-06 11:36:58,238 [ 31642] ERROR - llij.ide.plugins.PluginManager - IntelliJ IDEA 2018.3 Build #IC-183.4284.148
2018-12-06 11:36:58,238 [ 31642] ERROR - llij.ide.plugins.PluginManager - JDK: 1.8.0_152-release; VM: OpenJDK 64-Bit Server VM; Vendor: JetBrains s.r.o
2018-12-06 11:36:58,238 [ 31642] ERROR - llij.ide.plugins.PluginManager - OS: Linux
2018-12-06 11:36:58,238 [ 31642] ERROR - llij.ide.plugins.PluginManager - Last Action: EditorTab
2018-12-06 11:36:58,509 [ 31913] ERROR - llij.ide.plugins.PluginManager - kotlinx.coroutines.experimental.BuildersKt.launch$default(Lkotlinx/coroutines/experimental/CoroutineScope;Lkotlin/coroutines/experimental/CoroutineContext;Lkotlinx/coroutines/experimental/CoroutineStart;Lkotlin/jvm/functions/Function1;Lkotlin/jvm/functions/Function2;ILjava/lang/Object;)Lkotlinx/coroutines/experimental/Job;
java.lang.NoSuchMethodError: kotlinx.coroutines.experimental.BuildersKt.launch$default(Lkotlinx/coroutines/experimental/CoroutineScope;Lkotlin/coroutines/experimental/CoroutineContext;Lkotlinx/coroutines/experimental/CoroutineStart;Lkotlin/jvm/functions/Function1;Lkotlin/jvm/functions/Function2;ILjava/lang/Object;)Lkotlinx/coroutines/experimental/Job;
at com.intellij.openapi.application.impl.AppUIExecutorEx$DefaultImpls.execute(AppUIExecutorEx.kt:29)



Update to 2018.3.1.

If the issue persists, please file a bug at with the logs folder attached:


Thanks - the problem is still there. I will log a bug.


WebStorm 2018.3

Build #WS-183.4284.130, built on November 19, 2018
JRE: 1.8.0_152-release-1343-b15 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.1


This problem bothers me for a year, and still does.

This happens every time I create a new file. I need to change tab and return back to tab with newly created file, or swith focus to chrome browser and return back to WebStorm - the cursor reappears.

I think this is due to a popup with suggestion to add a new file to git, because, as i remember, project without VSC do not have this problem. 

JetBrains, please, do something! it is annoying



It was resolved for me when I removed OpenJDK and installed Oracle JDK 11.


i change the system time to the last time for testing , so it's happened to me

firstly  i thought it's worst by vim plugin,   i  turn on/off for much times but no helps.

that's ok immediately when i change the system time  correctly.


I can't edit any of html files, once i open any html file, the keyboard do nothing and i have this bug with html files and text files, i tried everything to fix it and i ended to use another idea for html files, works great!