Can't type in editor window



I'm running the latest EAP (142.2887.3) on OS X and I've lost all keyboard input within the Editor and Project windows.

When I type, nothing is changed in the editor windows.  IntelliJ hasn't hung, its just mot accepting any keyboard input.

The problem goes away when I open the Preferences window and type in the search box at the top left.  It's as though this can get my cursor focus but the main editor window can't.

I've only seen this once on the latest EAP and can't replicate it.

Has anyone else seen this problem?



Go to pycharm TOOLS  and  "turn off"  ur VIM EMULATOR .. or els just press ( ctr+alt+V )


I thought my PyCharm had a similar problem as Korolov had in because I couldn't type in an HTML file but could type in other files. My problem ended up being specific to a Django template tag. 

I had this code in my template:

{% templatetag garbage %}email{% templatetag garbage %}

This made it so that if I typed, a single character would output to the screen and then quickly be deleted.

Changing the code to:

{% templatetag openvariable %}email{% templatetag closevariable %}

Fixed my problem. Incorrect usage of a template tag should not break the IDE.




We have seen similar issues on Linux systems when user is rewriting PyCharm installation when updating to the new version, and installation becomes corrupt. If you're using Linux, make sure you're always installing into a new clean directory.

If that's not the case, please try the stable release 2019.1, and if the issue is still reproduced, follow the Serge's advice and contact support.


This is happening to me too, I'm running

IntelliJ IDEA 2019.1.3 (Ultimate Edition)
Build #IU-191.7479.19, built on May 27, 2019

on Mac 10.14.5 (18F132). For some reason I haven't figured out yet the editor stop handling any input, I can go through different files, navigate through the Project tree select a different file but not edit.

As a workaround I found out that pressing double shift to search a file and then returning to the editor fixed the problem.



You are facing one of a plenty focus related problems. We will need more details to recreate and fix it. Once you find out when this problem occurs, please, file a new issue and describe steps to reproduce:


Hi. I'm being crazy about this, I can not write [ and {

It's super weird, but all the other keys work perfectly.

it is not the keyboard assignment, these keys work well in any other application (safari, notes, emails, etc.)

I'm in Mojave 10.14.5 



What keyboard layout do you have?


Spanish ISO, I'm from Argentina, i dont think thats the problem, because only dont work in pycharm...



This issue was fixed:

However, the fix is not bundled with PyCharm yet. You can switch boot JDK to the following build:

See instruction on how to switch:


My bad,I was doing it wrong!!

Gracias che!!!


Just to confirm I had the original issues (unable to see editor prompt when selecting lines) just happen to me 5 Aug 2019. Went to preferences and typed something in and voila, back to seeing the cursor/prompt in the edit window.

Thanks for the help!

Build #PY-192.5728.105, built on July 23, 2019
Runtime version: 11.0.3+12-b304.10 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.6



There is a known issue on macOS when focus is lost after showing different dialogs:

Could you try applying a workaround from the header in issue description?


Many Thanks Arseniy - speedy response as usual! 


I've applied the fix now and will see how it goes. To be honest this doesn't happen often but when it does I usually restarted the IDE. All good!


In IntelliJ PyCharm, I had come across the same problem i.e., randomly keystrokes/type doesn't respond.

Unchecking "VIM EMULATOR" under PyCharm -> Tools menu, did fix the problem (I believe).


Confirming this issue happens in different versions of various Intellij products — the root cause are the plugins.

Check in Preferences which plugins are installed and remove the ones which are shown as incompatible.

This tends to happen after you upgrade the Intellij version but the plugins have still not been updated to support your current IDE version.


This is happening on my Mac with Ultimate 2019.3.3 version.


There is no VIM option or any other thing that I could tried or help. Every time this happens I have to restart. I am seriously considering switching to a text editor. This is beyond annoying. 


This was happening to me in PHPStorm. It was the "File Watchers" plugin. I deactivated that, then restarted PHPStorm. Then I set it back to active bc it is useful, and when I restarted the second time, all was good. There must have been a configuration issue with the plugin which is reset when de/activating


It was the "BashSupport Pro" plugin that caused it for me. Disabled it and I could type again right away.