The JDK 7 release from Oracle works only on Mac OS X Lion, and right now we don't want to restrict IntelliJ IDEA to Lion users only. We may consider fully switching to JDK 7 in the IntelliJ IDEA 12 timeframe, dependent on the adoption rates of Lion and Mountain Lion in our userbase.

Note that you can run IntelliJ IDEA under JDK 7 locally right now; you don't need to wait for a JetBrains-released JDK 7 version for that.

0

Hi Dmitry,

I was interested in trying this out, so I changed the JRE version specifier in the Info.plist to '1.7*'.
That resulted in an error on launch saying that no compatible JRE could be found, even though it works fine on the command line.

This is using the 11.1.1 community edition release version (117.117).

Is it possible that the launcher binary included in the application needs to be updated, or did I miss or mess up something else?

Thanks

0

The launcher binary is not compatible with the new JDK at all, unfortunately. You'll need to run idea.sh.

0

Any idea on when the launcher will be updated?  That's all that is needed to support running IntelliJ with JDK7.

0

We're working on it right now, but we don't plan to include the new launcher in the 11.1.x update releases.

0

Hi,

I changed the following lines in the info.plist

      <key>JVMVersion</key>
      <string>1.7*</string>



Now I switched to MacOS directory and tried to run idea file and the result was a message window telling "No compatible version of Java 1.7* is available." I have 1.7.0_04 installed in my machine as default Java.

Any idea what did i do incorrectly?

Thanks.
0

And where is idea.sh on IntelliJ 11.1?  Seems like it got removed.

0

I have this same problem.  I did find:

    /Applications/IntelliJ IDEA 11 CE.app/bin/inspect.sh

But, when I run that it does the same thing as launching from the icon:

$ '/Applications/IntelliJ IDEA 11 CE.app/bin/inspect.sh'
[JavaAppLauncher] Requested [1.6*], launching in [(null)] instead.
[JavaAppLauncher Error] unable to find a version of Java to launch

0

Is the launcher fixed yet for v12?  I just tried this (changing the Info.plist to 1.7*) on the latest EAP and it doesnt work.

0

Not yet, but it will be. The new launcher will use a completely different configuration mechanism (same as on other platforms) - there will be no info.plist any more.

0

Can you give us a rough timeframe for the new luncher? I guess it will be available for IDEA and AppCode at the same time (more or less)!?.
I'm really looking forward to get rid of Java6 on my Mac.

Stefan

0

The launcher is already included in the recent EAP builds of IntelliJ IDEA. It still uses Info.plist for configuring, so you can change 1.6* to 1.7* and it will use Java 7.

Note: don't do that if you actually want to get some work done in IntelliJ IDEA, and not just get rid of JDK 6. People seem to have an impression that JDK 7 will work better on Mac because 7 is greater than 6. It's absolutely not the case.

0

Tried this out of curiosity in latest EAP IU-123.23 and the ide fails to start, I get this in the console:

Nov 28 12:39:21 Zao com.apple.launchd.peruser.501[200] ([0x0-0xc80c8].com.jetbrains.intellij[1709]): Exited with code: 1

0

I also tried and got the same failure:

Nov 28 14:27:35 MBP com.apple.launchd.peruser.501[235] ([0x0-0x2dd6dd4].com.jetbrains.intellij[96993]): Exited with code: 1

0

Can you please try the following:
Open Terminal, in there:

> cd /Applications/IntelliJ<xxx>.app
> export IDEA_LAUNCHER_DEBUG
> Contents/MacOS/idea

and provide an output

0

2012-11-28 14:58:57.748 idea[4772:1803] Found Java Virtual Machines:
2012-11-28 14:58:57.749 idea[4772:1803] /Library/Java/JavaVirtualMachines/jdk1.7.0_07.jdk
2012-11-28 14:58:57.750 idea[4772:1803] /Library/Java/JavaVirtualMachines/jdk1.7.0_06.jdk
2012-11-28 14:58:57.750 idea[4772:1803] /Library/Java/JavaVirtualMachines/1.7.0.jdk
2012-11-28 14:58:57.751 idea[4772:1803] /System/Library/Java/JavaVirtualMachines/1.6.0.jdk
2012-11-28 14:58:57.751 idea[4772:1803] Required VM: 1.7*
2012-11-28 14:58:57.752 idea[4772:1803] Chosen VM:
2012-11-28 14:58:57.752 idea[4772:1803] /Library/Java/JavaVirtualMachines/jdk1.7.0_07.jdk
2012-11-28 14:58:57.762 idea[4772:1803] Reading at /Users/phill/Library/Preferences/IntelliJIdea12/idea.vmoptions failed, Error is: The file “idea.vmoptions” couldn’t be opened because there is no such file.
2012-11-28 14:58:57.763 idea[4772:1803] Reading at /Applications/Leda-IU-123.23.app/bin/idea.vmoptions OK
2012-11-28 14:58:57.764 idea[4772:1803] Reading at /Users/phill/Library/Preferences/IntelliJIdea12/idea.properites failed, Error is: The file “idea.properites” couldn’t be opened because there is no such file.
2012-11-28 14:58:57.764 idea[4772:1803] Reading at /Applications/Leda-IU-123.23.app/bin/idea.properties OK
Error occurred during initialization of VM
Could not find agent library yjpagent on the library path, with error: dlopen(libyjpagent.dylib, 1): image not found

0

If I remove "-agentlib:yjpagent=disablej2ee,disablealloc,sessionname=IntelliJIdea12" from the VMOptions it works. Lots of flickering until I closed the Hints dialog.
Seems OK though.
Ian

0

I did the above with Leda 123.23 and got the following output

Davids-MacBook-Pro:Leda-IU-123.23.app dpratt$ export IDEA_LAUNCHER_DEBUG
Davids-MacBook-Pro:Leda-IU-123.23.app dpratt$ Contents/MacOS/idea
[YourKit Java Profiler 11.0.4] Log file: /Users/dpratt/.yjp/log/12331.log


I did not get any debug output about loacting JDKs, nor did the contents of 12331.log indicate that either.



I then edited Info.plist to change the minimum java from 1.6* to 1.7* and got the following - (note, I did a java -version to ensure that java was properly installed as well - my bone-stock vanilla oracle JDK install went to /Library/Java/JavaVirtualMachines/jdk1.7.0_09.jdk)

Davids-MacBook-Pro:Leda-IU-123.23.app dpratt$ Contents/MacOS/idea
Error occurred during initialization of VM
Could not find agent library yjpagent on the library path, with error: dlopen(libyjpagent.dylib, 1): image not found
Davids-MacBook-Pro:Leda-IU-123.23.app dpratt$ java -version
java version "1.7.0_09"
Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)
Davids-MacBook-Pro:Leda-IU-123.23.app dpratt$

0

I actually had to use

export IDEA_LAUNCHER_DEBUG=""


before it started logging more details.
Without that, the export just exported the fact that the environment variable did not exist.

Otherwise the same experience, it dies on not finding a libyjpagent.dylib

On the community edition this would presumably work with fewer problems, since yourkit is not included.
0

Until we get an official word that IDEA 12 works well with JDK 7, I think I'll stick with using JDK 6.  When IDEA does complete support for JDK 7, I think IDEA should honor the default JVM configured inside the System Preferences Java preference pane when it launches.

0

That's probably the wisest approach for now.
I tested running on JDK 7, and while things work, I immediately spotted a glitch in the full-screen mode (extra blank space at the top of the screen).

The main reason some of us try to push this is that at some point, the Apple JDK 6 is going to become unavailable.
The next major OS X release is a possible/likely point for that to happen.

So I'm quite happy that it's at least possible now to run under JDK 7, and I'll probably test occasionally to see how it's progressing.

0

Oracle JDK won't support Retina display till version 8, this is due to rendering engine that is completely different in JDK 7. (The rendering pipeline in JDK 6 is proprietary to Apple).

So if Apple decides to remove the possibility to install JDK 6 in future OSX versions it'll either become ugly on retina displays, or tricky to get a running Apple JDK6.

Sources :
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8000629
http://lists.apple.com/archives/java-dev/2012/Oct/msg00144.html

0

Retina support has been backported to Java 7:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8009754

Java 7 Update 40 should be out in mid-September.

Best,
Ismael

0

Yes I've seen that in June while looking at a Stackoverflow question : http://stackoverflow.com/questions/15181079/apple-retina-display-support-in-java-jdk-1-7-for-awt-swing

That's good news indeed. However there is still some issues it seems as Kostentin Bulenkov reported in his blog : http://bulenkov.com/2013/06/23/retina-support-in-oracle-jdk-1-7/

0

Hello,

Got very good information from 2 links.

Thanks

0

Interesting. I hope that Kostentin has reported the issues to Oracle.

Best,
Ismael

0

It's already reported with tons of duplicates. The bad news is that these problems have been fixed in JDK 8 only and there are no plans to back port them to JDK 7 :-(

0

请先登录再写评论。