How do I change cursor from a block back to | ?

已回答

On my Mac, somehow, the caret indicating the typing position changed from | to a black filled rectangle. How do I get the

     |

caret back?

评论操作 固定链接

Hi Paul,

Have you looked under File > Settings > Editor > General > Appearance?
There is a check box for 'Use block caret' - maybe yours is checked?

HTH.

16
评论操作 固定链接

Block cursor indicates Insert mode. You can toggle it with Insert key.

Another possible reason is Block caret option enabled:

http://i.imgur.com/RKxIvHR.png

27
评论操作 固定链接

Thanks for the help guys!

I am on Mac, and this is in Android Studio. I never enabled the block cursor--it magically appeard when I accidentally typed some keyboard combination.

Any idea what key combination that might have been?

2
评论操作 固定链接

Insert key.

If you don't know which one, remap it here and hit it to toggle this mode:

http://i.imgur.com/Edzm4EW.png

8
评论操作 固定链接

If you have Vim installed, make sure that Vim Emulator mode is off (Alt+Cmd+V on Mac)

28
评论操作 固定链接

On a Mac there is no short cut to Enable or Disable the Insert mode. 

Just go to the Keymap section of preferences and add a Keyboard Shortcut for yourself to Toggle between the Instert/Overwrite cursor mode.

 

-1
评论操作 固定链接

How do you change the terminal block through a pipeline?

1
评论操作 固定链接

@NibragWeb you can't. According to https://www.jetbrains.com/help/idea/working-with-embedded-local-terminal.html#d899716e37

"Note that the setting Use block caret is not inherited in the terminal - its caret is always block."

0
评论操作 固定链接

FWIW, I had this problem recently on a new install of IntelliJ. I installed the IdeaVim plugin, thinking it was something else. The reason I had the block instead of the cursor was because the editor was in vim's View Mode as opposed to Insert Mode. In my case, I simply deactivated the plugin by going to Preferences -> Plugins, unchecking IdeaVim and restarting.

19
评论操作 固定链接

On my Mac keyboard toggle shortcut is: Fn+Enter.

Hope it helps, guys.

4
评论操作 固定链接

actvitymain de oluşturduğum editText i java class a nasıl işlerim ?

kendi oluşturduğum imleci nasıl kullanırım?(selam)

-2
评论操作 固定链接

Had this happen on a Mac while connected to a Windows machine via Remote Desktop, somehow while attempting to type open and closed curly braces (both of which typed). I couldn't find any solution to trigger it back, from attempting to finger-fumble re-discover the initial trigger, to all the suggestions here and some other sites. Nothing acted like Insert (including the ubiquitous clear+0 on the keypad).

Luckily, Insert mode is set per file (at least in my case), so closing and re-opening the file was an easy fix.

More importantly, I cleared the Insert/Overwrite shortcut from all my installations because I will never want that.

 

1
评论操作 固定链接

fn + ins(prt sc)  it gives back | .

3
评论操作 固定链接

@Josh Cummings this works perfect for me: "Preferences -> Plugins, unchecking IdeaVim and restarting"

 

thanks.

-1
评论操作 固定链接

bu tür yerlerde soruna çözüm bulamadığım için genelde bu tür yerlere başvuru yapmam. bi deneyim dedim ve tecrübem beni haklı çıkardı. sahipsiz kimsesiz başıboş liyakatsiz konumda bir site. kıytırıktan bir site.

-1
评论操作 固定链接

it is weird on mac when i open any file cursor indicates is Insert mode.

i need to switch in every file i opened.

and i can't type anything without switching several times.

And block caret option is not click.

.

sorry for my bad english.

 

0
评论操作 固定链接

Search "print screen" button on your keyboard and press it...
It worked for me coz "insert" and "print screen" are same button in my keyboard....

2
评论操作 固定链接

Go to Tools and unclick Vim Emulator and insert and ctrl+c, ... problems go away.

4
评论操作 固定链接

There's no 'INS' key on the Mac keyboard, so I was lost as to how this was happening. Then someone mentioned that it occurred when opening every new file which was the same as my scenario. Unchecking the Vim Emulator did the trick for me!

Thanks @Sdfor.

2
评论操作 固定链接

I have this very annoying problem: every time I open my python project, the cursor is in the caret mode... The "Use block caret" is switched off. I've tried to select the checkbox and then unselect it. Doesn't help. Please, help!

The version of the PyCharm:
PyCharm 2019.1.1 (Community Edition)
Build #PC-191.6605.12, built on April 3, 2019
JRE: 11.0.2+9-b159.34 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.4

My laptop:
MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)
macOS 10.14.4 (18E226)

1
评论操作 固定链接

Serge, thank you so much!! I've missed the comment about Vim.

0
评论操作 固定链接

I just encounter a similar problem and was confused. I noticed that the cursor changed because I pressed a certain key on my keyboard mistakenly. I pressed numeric key 0 and the cursor went back to normal

0
评论操作 固定链接

Serge your my hero i'm doing courses and was so close to giving up learning because this was stressing me out and ruining my code when i was looking away while typing following the instructor.... <3

0
评论操作 固定链接

I unchecked the Column Selection Mode option under the Edit menu in my case.

0
评论操作 固定链接

hey guys, its not just giving back the pipeline from the block, anyting i start typing between already typed content it just gets replaced with the present content,

 

also when i press the Enter button it doesnt go into the new line!!

 

could anyone help me out here!!! Please

0
评论操作 固定链接

Avokaayebilla96

 

this helped me,

Thankyou :)

0
评论操作 固定链接

I had to disable the IdeaVim Plugin. I wonder how JetBrains has never realized this issue. The IdeaVim plugin issue had been causing issues for me personally 

 

 

0

请先登录再写评论。