Prevent double click on tab from maximizing the editor?

已回答

Is it possible to disable having double click on an editor tab maximize the window? I never use this feature intentionally only accidentally.
I use i3wm and I float the run dialog, everytime I spuriously double click on an editor tab it messes up my entire desktop layout and it takes
sometime to fix it back up and knocks me out of my flow.

Thanks,
Ben

5

Please see https://youtrack.jetbrains.com/issue/IDEA-138797.

Starting from IntelliJ IDEA 2019.1 you'll be able to disable this behavior by adding -Deditor.maximize.on.double.click=false in Help | Edit Custom VM Options.

6

this double click functionality drives me crazy!

2

There is no way to disable it, sorry.

You can submit a request at http://youtrack.jetbrains.com/issues/IDEA .

0

The source may be my mouse is sensitive but I am facing this issue multiple time per day. I never double-click on a tab to maximize the IDE. I would like to disable this because it is more often messing my layout and interrupting my work.

If someone have a solution, please share.

Thank you!

0

@Roger I am on 2018.02 on Mac. `Window > Store Current Layout as Default` does not work in this case.

0

@Maciej

Odd...

I get the feeling the tab double-click feature is kind of bolted on, since it doesn't have the usual configuration options. Maybe that's why the the layout is not always properly restored as well.

Double-clicking the tab again does work in restoring the layout for me (Linux, and 2018.2.4).

In any case, seems like a solution is forthcoming :)

0

ohhhh.... so It's working when I double click again on tab with file name. I was clicking on Project tab ;)

Anyway I would expect the same behaviour in both cases.

0

@Maciej

Maybe everyone that posted here are in the same boat?

So your Project tab is still visible after maximizing the editor? When I maximize the editor, only the editor tabs remain visible.

 

 

0

Oh, those! I have them hidden since I rarely use the mouse for navigation.

Thank you for clearing up the mystery :)

0

Serge Baranov  you are amazing! thank you a thousand times! You make my life worthwhile again.

0

Hello. I want to have my project tab open after maximizing the editor. How can I achieve this? 

Adding the mentioned setting in vm options does nothing for me.

0

Wilczarz the mentioned registry option has been moved to IDE Settings | Advanced settings, Editor tabs ("Perform Hide All Tool Windows / Restore Windows with double-click on editor tab") and it enables hiding or showing all the tool windows, without an opportunity to leave only one of them.

Could you please describe your scenario in more details and share screenshots of the expected layout before and after double-clicking the Editor tab?

0

Ekaterina Valeeva In most cases I want to have the left panel always open. I rarely need the horizontal space. The monitor is wide and the code is properly formatted.

On the other hand, I often need more vertical space, as it's constantly hovered by search results that are docked on the bottom. So I want to double click the tab to hide the bottom panel.

I tried the option you mentioned, but now double clicking the tab does nothing, which is IMO worse that to fully maximizing the editor. Is there a way to achieve what I need?

0

Wilczarz I see the following options to hide the tool window in the scenario that you described:

- if you first perform search, open results in Find window, switch to the Editor and then would like to hide the Find tool window (the last one active), the Windows > Active tool window > Hide active tool window action (Shift+Escape) could do the trick. 

- there is a dedicated shortcut  Alt+3 to show or hide the Find tool window. 

- there's Dock unpinned view mode, in this mode tool window gets hidden as soon as focus is moved from it, you could use this mode for Find.

Does anything of the above work for you?

0

Thank you for your response. I already tried using Shift-Esc and Alt-3, but double clicking the tab is a habit that doesn't die easily. I will try the Unpinned mode, thanks.

Is there any chance you might implement excluding a panel from maximizing the editor in future development?

0

Wilczarz sorry for the long silence. I filed a feature request for this, please upvote IDEA-310159 and follow it for updates.

0

@Sebastien DErrico

Sounds like your workflow is to click the tabs to switch editors? If so, consider using the keyboard shortcuts instead. It's faster and more convenient, and neatly resolves the tab double-click issue as well.

If you double-click the tab again after the first double-click, does it restore the layout? If not, have you tried `Window > Store Current Layout as Default` and then `Window > Restore Current Layout (Shift+F12)` to restore things after a tab double-click?

-1

请先登录再写评论。