Recent discussion here convinced us to implement @nullable and @nonnull annotations
in 'constant conditions & runtime exceptions' aka 'data flow analysis' inspection.
The final question is quite simple: how those annotations should be named
and in what package they should reside?
The variants so far are as follows:
@nonnull, @notnull, @NotNull, @NonNull
as to package, org.jetbrains comes to my mind.
"Develop with pleasure!"