[solved]Why is the subversion feature not available?

Hi everyone, at work my co-workers IntelliJ lets him create a new project by checking out code from my repository. However when you modify a file nothing shows as modifide in the listing, and if you right click on the file or the directory to select Subversion commit directory the 'subversion' option is not available at all in the context menu. If you try and use the Version control menu bar option and tell it to commit changes it says no changes detected.

What are we missing? The only difference between his and mine is that he is currently using a 30 day trial where I have a full license version I got last month.

Any help would be appreciated.


Go to Settings -> Version Control and choose for directory <Project Root> VCS -> Subversion
There is no autodiscovery


Can you clarify a bit more. Looking at Settings > Version Control > VCS s > Subversion

What am I to do, I do not understand what you are saying to modify.


provided you have checked out the project that is under subversion you can add subversion support as shown in the attached pic.


IntelliJ auto discovers that the project is under Subversion control by the hidden .svn directories that result from a Subversion checkout. The only thing that comes to mind if this is not happening is that maybe your co-worker inadvertently disabled/uninstalled the Subversion plugin. Have you checked this?

Also, did manually setting the project to use Subversion per Tilman's screenshot solve the issue? That is the setting IntelliJ normally sets automatically based on the existence of the .svn directories.


Thanks all for responding. Unfortunately the person was let go last Friday. However, today I pulled a project from

Subversion using IntelliJ create project form repository option and I too am unable to check the code back in using IntelliJ. I can use tortoise SVN to commit and update on that project but intelliJ is not giving me the option to do so. When I get back in the office in the morning, I will try as the screen shot shows to see if I can do anything with it.


I always checkout code with the command line then create a project in IntelliJ based on those sources. I have never used the checkout from within IntelliJ so we probably aren't comparing apples to apples.


This was most helpful. I was able to correct the svn path for my local directory. I will pass this information along to the others.

Thank you all for your assistance.


Just in case, if you couldn't find SubVersion in the path: "Settings > Version Control > VCS s -> " then, go to "Settings -> Plugins", search for subversion, then install it and then enable it.
Now, you can easily find it under "Settings > Version Control > VCS s ->"

Now, you can add your project repo path under "Settings > Version Control > VCS s -> Directory Mappings ->" and Select the VCS column value to Subversion. Apply and issue resolved.