cvs problem

Hello. I'm having a problem with Intellij IDEA 4.0 (i'm currently testing the trial version).

After i create a new module, i want to check out some files from a CVS repository. These are mostly .jar files, with sizes of a few megabytes.

The checkout procedure goes well, no errors are reported, but if i then check the files retrieved, they are all only a fraction of the actual files in the repository (few hundred bytes each).

I've tried to do the same process using the command line tool and it works fine (i'm using the same CVSROOT in both cases).

I've tried to use two different types of connections to the repository. SSHv1, which is somehow slower... And ext, giving it SSH as the external tool. I also have the CVS_RSH env variable setup in my environment, but i guess IDEA won't read this as it has a field to pass it in in the options.

I haven't been able to see anyone with the same or a somehow similar problem... Do you have any idea why this happens?

My system is running RedHat9.

Thanks in advance,
Ricardo Rocha

PS: Is there a chance IDEA will support in the future local repositories? If i directly give a directory in my CVSROOT to the cvs command line tool, it accepts and deals with it nicely. This doesn't seem to work in IDEA.

评论操作 固定链接

We're having huge problems with IDEA 4.0 CVS (silent failure to completely update/commit files) ever since the switch to DST. It doesn't affect everyone (which is very strange) but occurs to 50% of our developers.