undo / redo



Just noticed that the undo / redo function seems unusual :-)
I am used too the ctrl-z being undo, but there is usually the equivalent ctrl-y for redo

I havent yet worked out what ctrl-y does but it is definately not redo
Is there a redo function anywhere and when so what keyboard shortcut is it mapped to ?
Oh and what exactly does ctrl-y do (appart from messing up my code) :-)



I was also extremely annoyed by this strange behaviour. But luckely, it seems that some smart developer at JetBrains was expecting this

Click File --> Settings --> Keymap
In that screen there is an option labeled Keymaps. Set this to Eclipse and hit OK.

Now you can use Ctrl+Z and Ctrl+Y, and a lot of other standard keys.


Shortcuts are displayed in all menus and action lists. Redo is under Edit main menu and is set to Ctrl-Shift-Z in default keymap. Ctlr-Y is mapped to Delete Current Line.


ahhh thanks

and now just out of curiosity what did ctrl-y do ?


The intent behind of having Eclipse keymap is only to help evaluators with Eclipse background to taste at least some basic features.
The problem is that IntellJ Platfrom philosophy and design and thus architecture and features are quite different from eclipse's (despite the fact that many eclipse's features are direct clone of ours). In most cases our features can't be mapped to eclipse's terminology. And if one decided to use IntelliJ platform based product and trying to make it look or behave like eclipse instead of adopting – he/she is simply wasting time.


i've discovered the remap keyboard shortcuts -so saved my own scheme abd can fiddle about there with my own settings !



Nice m8 i was so annoyed by this now i can wrk propperly.


ctlr+y delete line



so I have undone 15 actions, and wanted to redo all that, so I held ctrl+Y for quite a bit deleting over 10 lines. how do i recover to normal? thanks


Ramiz, could you please describe step-by-step the whole scenario?

Did I get it correctly?

- You made some actions (f.e., typed some code);

- Then you have undone these with Ctrl+Z;

- You deleted some lines with Ctrl+Y.

And your current goal is to return to the state from the first step (to the same code you have typed)?


I had to recover from git and start over, so it worked fine. but yeah that was initially the problem. I'm good now


this is honestly not an acceptable default hotkey for it.

ctrl+y is redo. changing this to "delete" as default is a subpar decision.


It seems JetBrains finally capitulated! They now ask if you want to set Ctrl+y to mean what it means in literally every other program.


Lost code again because of this stupid shortcut. 

The strange thing is: I already remove it from Keymap, but, for some reason it's is resetting again, possible from any old webstorm version from my mac or resetting from upgrades.

And already responded to change ctrl+y behavior and it seems that it keep returning from the crypta.

WebStorm 2020.3


This is so frustrating, pressed ctrl y in rider to undo code and it deletes code, wtf? 


When is Jetbrains going to change the default behavior to redo a line when pressing CTRL + Y instead of deleting it and making things even worse ?


This isn't planned afaik. When you use Ctrl+Y for the first time - you're asked what action do you prefer to be assigned to it:

You can also change the shortcut anytime at File | Settings | Keymap.


The popup that asks if you want to map CTRL+Y might show up once, but thanks to a product update overnight, not only did my start menu shortcut to WebStrom get deleted yet again, all of the key mappings have reset!  I just did a dozen 'Undos' with the standard CTRL+Z, and wanted to redo them with the industry-standard key mapping of CTRL+Y. Instead I deleted 12 lines of code and had to go Googling again to remind myself what stupid random keys JetBrains chose for 'Redo'. There was no popup asking if I wanted CTRL+Y to mean one thing or another.

CTRL+Y is international industry-standard.  Why change it? I'm really glad they didn't make CTRL+C something like 'delete file with no confirmation dialog and no recycle bin' and CTRL+V to mean 'shut down server' or some other stupid thing. CTRL+Y is "redo" just like CTRL+C is "copy".

If you can't stick to accepted standards, at least DO NOT BLOW AWAY THE USER'S SETTING WHEN YOU RELEASE A MINOR UPDATE!!!


After 14 years, the problem is just partially solved. The muscle memory is very fast, and unfortunately I lost some work. Thanks.
Set CTRL-Y and CTRL-Z to work as expected. Nothing will change for anybody, since the users that are used to the wrong IntelliJ shortcut also know the normal ones, since they are the same in all other programs . The popup question asks only for CTRL-Y and not for CTRL-Z, anyway.
So i setted up Undo and Redo as they must be, and removed the shortcut for the useless “delete line”.
Until the next reinstallation