To open “AppCode” you need to install the legacy Java SE 6 runtime.



All JetBrains products are currently unusable on Mac, giving an error like that in the title.

Installing a (nearly) decade-old security tarpit is not an option.  Period.

What is the work around, and if there are none, when will the products be operable on mac?



Actually, another way to force specific Java version that prevents code signing issues was introduced.
Please refer to the following post for details.

Java 6 is the last bug-free Java release on OS/X. Java 7 and Java 8 (and Java 9) exhibit GUI defects for complex Swing/AWT apps on OS/X. There's not much of a security issue if you're not running Java applets with Java 6. That said, all of the JetBrains products will run fine on Java 7 and Java 8 (not counting JDK bugs). Edit the Info.plist file in the application package and look for this stanza:


You can change the 1.6* to the Java version you have installed, e.g., 1.7.

JetBrains attempts to force the use of 1.6 to prevent bug reports about font problems, discrete GPU forcing, etc.

That is true, but please be aware that any changes inside bundle can break the app's signature. So if firewall is turned on, security alert messages can pop up.


Is there any update here? I received the error asking for 1.6 today with the recent version and the info.plist contains 1.8* or 1.8+.


^ Above problem was solved via Zendesk ticket.