PyCharm stops responding to the keyboard input

Hi all,

I have an issue that keeps popping up where PyCharm completely stops responding to the keyboard.  The keyboard still works in the rest of the OS and PyCharm still responds to mouse inputs.

When it happens it happens to all open instances (I often have 2 projects open at once) but closing them all and reopening them "fixes" the issue.

I'm not sure what triggers the issue but I will try to give as many details as possible.  I've had this happen on two different machines running Ubuntu and never in Windows on the same machines.

Ubuntu Gnome 14.04 (yes it's in beta)
PyCharm 3.1.1 Professional
java version "1.8.0"
Java(TM) SE Runtime Environment (build 1.8.0-b129)
Java HotSpot(TM) 64-Bit Server VM (build 25.0-b69, mixed mode)

Ubuntu 13.10 (Unity)
PyCharm 3.1.1 Professional
java version "1.7.X" (can't remember the exact numbers)

Ubuntu 13.10 (Unity)
PyCharm 3.1.1 Professional
java version "1.6.X" (can't remember the exact numbers)

Is this a known problem or am I in a broken world of my own?

It is known, , but it looks like jetbrains thinks the problem is in X or ibus or java, not pycharm.

I don't know offhand if there are entries in the ubuntu bug tracker (launchpad) for this bug in those other components.


I just ran into this issue on my Ubuntu 14.04 system running pycharm professional 2018.1.4

PyCharm 2018.1.4 (Professional Edition)
Build #PY-181.5087.37, built on May 24, 2018
Licensed to Michael Uman
You have a perpetual fallback license for this version
Subscription is active until June 23, 2019
JRE: 1.8.0_152-release-1136-b39 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.4.0-66-generic

I was working with a source file, added a new file, and then suddenly my keyboard was not responding in the IDE. But the keyboard works in all my other apps.

I love pycharm and hope that such a bug like this could be crushed speedily.


Thank you,

Michael Uman



I have experienced this same issue. restarting the project window I'm working on 'fixes' it.


I had this problem with just one file of a project, just reopening it 'fixes' it too. It is as if you are not working on the active tab. It happens typically after running your source.


Hey guys I think... think I may have stumbled into the solution. I think it's mac's accent keys. When you hold down a key for an extended period on a mac it will show you options for accent keys like > ñ or ê. If you hold down a key this activates, but doesn't 'release' in pycharm. to turn this off:

Open Terminal and enter: defaults write -g ApplePressAndHoldEnabled -bool false

or (for Mavericks)

Open Terminal and enter: defaults write -g ApplePressAndHoldEnabled -bool NO

Restart PyCharm and this should solve the issue.

Follow-up: I've tested this now for 4 days and have had no problems. I'm certain this is the cause.

If Jetbrains could disable the long key hold (special character) at start-up of the program, this would solve the issue.

Hope this help someone.


I have the same issue on my Ubuntu 18.04 with Unity with IDEA IntelliJ 2018.2.5 (Ultimate Edition). It seems to be an IntelliJ - ibus problem. 

The command 
$ ibus-daemon -rd
fixes the problem without restarting IntelliJ.

I found this workaround on a rather old blog entry: 



@Unitedideas  thanks a lot!

Definitely accent keys are to blame here.

There is an even simpler solution that worked for me at least - just "long press" any key to "unfreeze" the keyboard.

For me the problem starts with the "long press" of any key - then the keyboard freezes. "long pressing" a key unfreezes it.

Hope this helps. Much better than restarting :)


Siegfried Huber's solution also worked for me on Debian 10.  Anyone know if it's advisable to permantely disable ibus-daemon?


UPDATE: I found this article.  I selected "none" as the input method on my system.  Not sure if it helps yet, but seems promising.


Pycharm has just lost the keyboard input from the latest update. How do I roll back to the last stable version of pycharm, which worked flawlessly. Or do I just search out another platform which is stable and not broken?



Hello @Icanfigure


just uninstall the current version and install the previous version from .

If you wish to investigate this, please  upload your logs folder zipped from ***Help | Collect logs and Diagnostic Data***   to the FTP and please let me know the filename. 



Still happens for me. Tried workarounds in this thread and stackoverflow, but the issue is not gone. I'm not sure it's worth to pay for a tool - what am I asking from IDE? To allow me to type? And seems like this doesn't work.



Do you have Tools | Vim Emulator enabled by any chance?
If not, could you file an issue to and attach your idea.log file from Help | Show Log in... so we can investigate it?



I am using ubundu 19.04 and this keeps happening.

Any solution for this please.

Thank you


What helped me is adding to ~/.bashrc:




I just had this happen with the upgrade to 2023.2.3 on MacOS. Only some keyboard functions wouldn't work. I could enter text, but not backspace. Cmd-z would work, but not Cmd-f. I fell back to the previous version and the problem went away.


The same thing happened to me, Pycharm 2023.2.3 on Ubuntu 22.04. You can type letters, but no backspace etc…




Do you use IdeaVim plugin? Please try to disable it. It might be 


It is indeed, thank you!


I updated IdeaVim, disabled it, and reinstalled the latest version of PyCharm. The keyboard worked normally. When I check IdeaVim had been reenabled so the latest version of IdeaVim has fixed the problem.


Disabling the IdeaVim resolves the issue.