Pycharm conda env not showing packages installed via pip


Running Pycharm 2016.1.2, using Anaconda 4, with a `conda` env running Python 3.5.1 on Windows 10.  Pure python project, planning on doing some development using `bottle`.  Created said conda env using PyCharm.

No bottle available according to conda, either in PyCharm or from the command line.  In Windows PowerShell, changed to the desired env, and used pip to install bottle.  Running `conda list` shows bottle as being installed... but it doesn't show up in the list of packages under 'File > Settings > Project Interpreter', and PyCharm isn't able to autocomplete anything involving bottle, and when I run the script from PyCharm it errors out, not being able to find or import bottle.

But when I run the same script from the command line after activating the conda env, it works just fine.

Any ideas on why the same conda env in PyCharm can't see the packages installed by pip?


I observe the same problem on Ubuntu 17.10, am using conda 4.4.7


I am experienced it with PyCharm 2017.3, Windows 10 Pro, conda 4.3.30, `djangorestframework==3.6.4` package installed via pip in Conda environment. This package appears in `pip freeze`, but missed in PyCharm | File | Settings | Project Interpreter. The corresponding issue is already registered


For future references: there's a special button in recent versions of PyCharm to switch between conda and pip:


Thank you Pavel Karateev. Your answer fixed my problem! I just disabled the switch and now I see all my packages when I click + (