Hitting Breakpoints with IntelliJ Idea 10 and La Closure Plugin version 0.3.15

I'm using IntelliJ Idea 10 with the La Closure plugin version 0.3.15 and Java 6 I've added Clojure 1.2 to a project.

The breakpoints I put on Java code get hit, but the ones I put on Clojure do not. in fact, if the debugger is stopped on a Java breakpoint, the breakpoints on Clojure code have an x in them and they have a warning that says, for example, No executable code found at line 4 in class at debugland$eval3.

I've tried putting breakpoints in Clojure core functions like println, but I still get the red x's. Would really, really appreciate any help on this. I've tried Idea 9 with both Clojure 1.1 and 1.2 with similar results.


Hello Tamara.

The problem with debugger is fixed now and will be available for download in a few days. So far, as a workaround you can put some breakpoints into Java code that is called from Clojure. In this case you willl have some stack structure above, which contains clojure classes, to inspect.

With best regards,