Symfony2 Plugin not installed with DrupalSymfony2 Bridge, and not even available.

I'm attempting to follow the instructions for installing the Symfony2 plugin, and the plugin is not being installed. Instead of getting the Symfony2 plugin, I just get the Symfony plugin. I've tried completely un-installed the bridge and Symfony plugins and re-installed, but the output is still the same; I don't see the Symfony2 plugin option as is shown in the above-referenced documentation. The documentation link in the Symfony plugin takes me to the Symfony2 plugin docs page, but I'm wondering why I don't get the Symfony2 config options as shown in the PHPStorm documentation. In addition, if I go to Browse repositories in the settings, I only see the Symfony plugin, not Symfony 2.

Am I missing a step somewhere? 

I'm on 2016.1 for Mac.





Thank you for reporting, the tutorial will be updated soon!

Hi there,

That manual was done quite some time ago and does not reflect the state of things in latest IDE versions although everything is still discoverable (Hint: Settings screen has search box -- try it next time)

1) "Symfony2 Plugin" was renamed to just "Symfony Plugin" to better reflect the fact that it also supports Symfony3 --

2) The settings for this plugin now located under "Settings/Preferences | Languages & Frameworks"


Hint: I did use the search box - quite a bit, actually. As I stated above I found the Symfony plugin - and everything else you described above - just fine. The question was about the fact that what I was seeing didn't match what the official documentation stated.