Class Resolution Issues with Scala Plugin

I am having some serious issues with the latest verison of the Scala plugin.  Occassionally when refactoring projects something gets knocked out.  For example a file like so,

Screen Shot 2012-10-12 at 09.42.16.png

Api is clearly in the same namespace and everything compiles and runs perfectly.  If i rename the project and then generate the IDEA files again (./sbt idea) SOMETIMES this fixes it for a while but I cant find a pattern to reproduce this.  As a side effect something happens to the project structure in IDEA.  Basically the right context menu usually offers the following options,

Screen Shot 2012-10-12 at 09.41.54.png

But after things go up the left the options change to this,

Screen Shot 2012-10-12 at 09.41.44.png
I've tried uninstalling and reinstalling IDEA and the Scala project, clearing various caches but still no workable fix.  

Is there anything else I can try?


Is it possibile to create sample project on which is reproducible sometimes? I have few similar issues in issue tracker, but I wasn't able to understand what's the problem, so I really need to reproduce it.
As workaround, you can try to install some previous plugin version (can you provide plugin version with this problem and plugin version without this problem).

Best regards,
Alexander Podkhalyuzin.


It's next to impossible to to reproduce the issue predictably I'm afraid.  As for the version - I am currentyl using         0.5.983 but am having trouble downgrading due to missing dependencies.


What's missing dependencies problem? You can try any of 0.5 builds:
What's about IDEA 12 with plugin of 0.6 version? Can you try it?

Best regards,
Alexander Podkhlayuzin.


Installed the latest community EAP and the 0.6 version of the plugin.  Alll appears to be working fine.


Ok, then it's even more weird for me...


Thats not to say that the issue wont just happen again on EAP.  As I've said before sometimes it just works for a while and suddenly BOOM it's gone again.

I'll keep you posted if any other issues arise.



This happens to me too. I simply delete ~/.IntellijIdea12/system folder and everything starts working again
Would like to help, but currently don't know how )