Can't seem to move past 1939

I again tried to move up, this time to 1994. After refreshing my maven projects, the plugin created the facets, but did not assign a scala compiler.

I specify


Should I expect that that plugin would configure the facet with this compiler as it used to?

Well, I was willing to set it manually, but my options to do so look like:

ScreenHunter_01 Aug. 10 11.10.gif

I have these errors in the log:

2010-08-10 11:04:15,663 [92693564]  ERROR - ij.components.ComponentManager - Not disposed pointer: listener=null
Creation trace null

java.lang.RuntimeException: Not disposed pointer: listener=null
Creation trace null

 at com.intellij.openapi.vfs.impl.VirtualFilePointerImpl.throwNotDisposedError(
 at com.intellij.openapi.vfs.impl.VirtualFilePointerManagerImpl.assertPointersDisposed(
 at com.intellij.openapi.vfs.impl.VirtualFilePointerManagerImpl.disposeComponent(
 at com.intellij.openapi.components.impl.ComponentManagerImpl.disposeComponents(
 at com.intellij.openapi.application.impl.ApplicationImpl.dispose(
 at com.intellij.openapi.util.Disposer$1.execute(
 at com.intellij.openapi.util.Disposer$1.execute(
 at com.intellij.openapi.util.objectTree.ObjectNode$1.execute(
 at com.intellij.openapi.util.objectTree.ObjectNode$1.execute(
 at com.intellij.openapi.util.objectTree.ObjectTree.executeActionWithRecursiveGuard(
 at com.intellij.openapi.util.objectTree.ObjectNode.execute(
 at com.intellij.openapi.util.objectTree.ObjectTree.executeAll(
 at com.intellij.openapi.util.Disposer.dispose(
 at com.intellij.openapi.util.Disposer.dispose(
 at com.intellij.openapi.application.impl.ApplicationImpl.d(
 at com.intellij.openapi.application.impl.ApplicationImpl.access$100(
 at com.intellij.openapi.application.impl.ApplicationImpl$
 at com.intellij.openapi.application.impl.ApplicationImpl.exit(
 at com.intellij.openapi.application.impl.ApplicationImpl.exit(
 at com.intellij.openapi.wm.impl.IdeFrameImpl$2$
 at com.intellij.openapi.application.impl.LaterInvocator$
 at java.awt.event.InvocationEvent.dispatch(
 at java.awt.EventQueue.dispatchEvent(
 at com.intellij.ide.IdeEventQueue.f(
 at com.intellij.ide.IdeEventQueue.b(
 at com.intellij.ide.IdeEventQueue.dispatchEvent(
 at java.awt.EventDispatchThread.pumpOneEventForFilters(
 at java.awt.EventDispatchThread.pumpEventsForFilter(
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(
 at java.awt.EventDispatchThread.pumpEvents(
 at java.awt.EventDispatchThread.pumpEvents(
2010-08-10 11:04:15,697 [92693598]  ERROR - ij.components.ComponentManager - IntelliJ IDEA 9.0.3  Build #IU-95.429
2010-08-10 11:04:15,698 [92693599]  ERROR - ij.components.ComponentManager - JDK: 1.6.0_20
2010-08-10 11:04:15,699 [92693600]  ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) 64-Bit Server VM
2010-08-10 11:04:15,699 [92693600]  ERROR - ij.components.ComponentManager - Vendor: Sun Microsystems Inc.
2010-08-10 11:04:15,699 [92693600]  ERROR - ij.components.ComponentManager - OS: Windows 7
2010-08-10 11:04:15,699 [92693600]  ERROR - ij.components.ComponentManager - Last Action: Vcs.UpdateProject

Does nobody else seem to have these problems? How can it be only me?

the plugin is broken above 1939 for about anyone i think. 2000 also doesn't fix the (my) problems


Previous versions of the plugin considered "scala-compiler" dependency as a Scala compiler, that was a misbehavior.
Dependency on "scala-compiler" artifact has nothing to do with Scala compiler.
See this message for details.


May I see a pom.xml that is causing these troubles (including ones with encoding)?


Sorry Pavel, my pom also has:


I don't specify the goals or the scala version like in the thread you referenced, but the plugin is indeed executed for those goals with the correct version so I assume they are the defaults.

Just to be clear, in that thread you referenced you said:

"Such declaration should be automatically imported by IDEA as a Scala compiler library for facet.
(regular dependencies, like scala-library, should be imported as well - as entries in module dependencies list)."

So, with the above I should NOT have to specify the compiler in every module via the facet, correct? If so, this is not the behavior I am seeing. But I'll try adding the goals and the configuration sections and see if that helps.

What do you mean by "encoding"?


My iml file have the following:

  <component name="FacetManager">
    <facet type="scala" name="Scala">
        <option name="compilerLibraryLevel" value="Project" />
        <option name="compilerLibraryName" value="maven: org.scala-lang:scala-compiler:2.8.0" />

Which looks to be correct. I can start FSC and it seem to be up and running ok. But when I try to compile I get a popup saying

  "Please, adjust compiler library in Scala facet: multiple scala-compiler-*.jar's attached."

mvn dependency:tree shows this is not the case.

Anyway I have attached all my poms and the ipr and iml files for the project.



Pavel, is there anything I can provide?


I'm working on import right now, the project sample you attached was a great help to me.
Maven import is becoming significantly better :).


Thank you, thank you!


You are welcome. Check the next nightly build.

(your project deals with all possible technologies at once, looks like some AI implementation :))


I'm back on the edge! I've been able to upgrade to 2026. The scala-compiler in the module setting still displays as corrupt (ie, the squares) but all seems to work. I'm assuming that that corruption is an issue with Idea/Maven, as I see it in the maven dependency tree view as well. (Actually, thats the first time I saw the problem.)

Thanks Pavel!!


One downside however is that if I even open the module settings then all the Idea message from that point are little squares. For example after doing  a full build the popup that would say the build completed is a string squares. Of course this would also be the case if I [tried to] viewed the maven dependency tree. Restarting Idea clears things up.