Debugger not working in Ruby 1.9.3

Hi,

As always, first things first: Thanks for a fantastic product!

Now for the whining and complaining ;)...

I recently upgraded to Ruby 1.9.3 so I suspect that might be the reason my debugger does not start.

I am using the following:

Ruby 1.9.3
Rails 3.1.1
RubyMine 3.2.4
Ubuntu 11.04

And this is what I get when I try to fire up the debugger (which has worked fine in the past):

Cannot connect to the debugged process at port 50721 in 10s:
Error Output:
/home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/linecache19-0.5.11/lib/trace_nums19.so: undefined symbol: ruby_current_thread - /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/linecache19-0.5.11/lib/trace_nums19.so (LoadError)
    from /home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/linecache19-0.5.11/lib/tracelines19.rb:12:in `rescue in <module:TraceLineNumbers>'
    from /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/linecache19-0.5.11/lib/tracelines19.rb:8:in `<module:TraceLineNumbers>'
    from /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/linecache19-0.5.11/lib/tracelines19.rb:6:in `<top (required)>'
    from /home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/linecache19-0.5.11/lib/linecache19.rb:69:in `<top (required)>'
    from /home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:59:in `require'
    from /home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in require'
    from /home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
    from /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/ruby-debug-base19x-0.11.30.pre4/lib/ruby-debug-base.rb:3:in `<top (required)>'
    from /home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /home/larry/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/ruby-debug-ide-0.4.17.beta8/lib/ruby-debug-ide.rb:5:in `<top (required)>'
    from /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/ruby-debug-ide-0.4.17.beta8/bin/rdebug-ide:17:in `require_relative'
    from /home/larry/.rvm/gems/ruby-1.9.3-p0@stuptues/gems/ruby-debug-ide-0.4.17.beta8/bin/rdebug-ide:17:in `<top (required)>'
    from -e:1:in `load'
    from -e:1:in `<main>'

Any ideas?

Thanks,
Larry

0

OSX..  I think 10.4.. not sitting at it right now..      I run RVM..

0

Please check that Computer Name is specified in System Preferences | Sharing

0

This fixed it for me!  I had just migrated my mac os install from another machine and the computer name wasn't set.  How annoying!  Perhaps the jetbrains folks could find a way to check for this when trying to run debug and throw an error message if it doesn't exist.

0

Hi @Dennis Ushakov,

I have been running into this problem for a very long time now. I made sure my System Preference -> Sharing has a name and yet still unable to rubymine debugger to work. Any clues?

gem list | grep debug

debugger-linecache (1.2.0)

debugger-ruby_core_source (1.3.8, 1.1.6)

ruby-debug-ide (0.6.0)

 

Thanks,

Helen Z

0

@Helen,

what exact problem are you experiencing? What kind of the project? And that's 1.9.*, right?

0

apologies for not stating all my information (rubymine 8.0.3, rvm ruby 2.2.2) 

mbp-0630:avant-basic hzhang82$ which ruby

/Users/hzhang82/.rvm/rubies/ruby-2.2.2/bin/ruby

mbp-0630:avant-basic hzhang82$ which gem

/Users/hzhang82/.rvm/rubies/ruby-2.2.2/bin/gem

mbp-0630:avant-basic hzhang82$ which bundle

/Users/hzhang82/.rvm/gems/ruby-2.2.2@avant_basic/bin/bundle

mbp-0630:avant-basic hzhang82$ which rails

/Users/hzhang82/.rvm/gems/ruby-2.2.2@avant_basic/bin/rails

mbp-0630:avant-basic hzhang82$ gem env

RubyGems Environment:

  - RUBYGEMS VERSION: 2.6.2

  - RUBY VERSION: 2.2.2 (2015-04-13 patchlevel 95) [x86_64-darwin14]

  - INSTALLATION DIRECTORY: /Users/hzhang82/.rvm/gems/ruby-2.2.2@avant_basic

  - USER INSTALLATION DIRECTORY: /Users/hzhang82/.gem/ruby/2.2.0

  - RUBY EXECUTABLE: /Users/hzhang82/.rvm/rubies/ruby-2.2.2/bin/ruby

  - EXECUTABLE DIRECTORY: /Users/hzhang82/.rvm/gems/ruby-2.2.2@avant_basic/bin

  - SPEC CACHE DIRECTORY: /Users/hzhang82/.gem/specs

  - SYSTEM CONFIGURATION DIRECTORY: /etc

  - RUBYGEMS PLATFORMS:

    - ruby

    - x86_64-darwin-14

  - GEM PATHS:

     - /Users/hzhang82/.rvm/gems/ruby-2.2.2@avant_basic

     - /Users/hzhang82/.rvm/gems/ruby-2.2.2@global

  - GEM CONFIGURATION:

     - :update_sources => true

     - :verbose => true

     - :backtrace => false

     - :bulk_threshold => 1000

  - REMOTE SOURCES:

     - https://rubygems.org/

  - SHELL PATH:

     - /Users/hzhang82/.rvm/gems/ruby-2.2.2@avant_basic/bin

     - /Users/hzhang82/.rvm/gems/ruby-2.2.2@global/bin

     - /Users/hzhang82/.rvm/rubies/ruby-2.2.2/bin

     - /Users/hzhang82/.rvm/bin

     - /usr/local/bin

     - /usr/bin

     - /bin

     - /usr/sbin

     - /sbin

     - /usr/local/sbin

     - /usr/local/MacGPG2/bin

     - /usr/local/sbin

     - /Applications/Xcode.app/Contents/Developer/usr/bin

     - /Users/hzhang82/Downloads/ruby-2.2.4/bin

Here is my gem list:

gem list

 

*** LOCAL GEMS ***

 

actionmailer (4.2.6)

actionpack (4.2.6)

actionview (4.2.6)

activejob (4.2.6)

activemodel (4.2.6)

activerecord (4.2.6)

activesupport (4.2.6)

arel (6.0.3)

bigdecimal (1.2.6)

builder (3.2.2)

bundle (0.0.1)

bundler (1.11.2)

bundler-unload (1.0.2)

concurrent-ruby (1.0.1)

debase (0.2.2.beta6)

debase-ruby_core_source (0.8.4)

erubis (2.7.0)

executable-hooks (1.3.2)

foreman (0.78.0)

gem-wrappers (1.2.7)

globalid (0.3.6)

i18n (0.7.0)

io-console (0.4.3)

json (1.8.1)

loofah (2.0.3)

mail (2.6.3)

mime-types (2.99.1)

mini_portile2 (2.0.0)

minitest (5.4.3)

nokogiri (1.6.7.2)

power_assert (0.2.2)

psych (2.0.8)

rack (1.6.4)

rack-test (0.6.3)

rails (4.2.6)

rails-deprecated_sanitizer (1.0.3)

rails-dom-testing (1.0.7)

rails-html-sanitizer (1.0.3)

railties (4.2.6)

rake (10.4.2)

rdoc (4.2.0)

ruby-debug-ide (0.6.0)

rubygems-bundler (1.4.4)

rvm (1.11.3.9)

sprockets (3.5.2)

sprockets-rails (3.0.4)

test-unit (3.0.8)

thor (0.19.1)

thread_safe (0.3.5)

tzinfo (1.2.2)

 

Interestingly I am experiencing two problems... for the exact same project, same code under two different directory:

1. The first repo gives me [No Rails found in SDK] error. (I read a few forums and none seems to help)

2. The second repo gives me "Cannot start debugger. Gem 'ruby-debug-ide' isn't installed or its executable script 'rdebug-ide' doesn't exist" which is documented here: https://intellij-support.jetbrains.com/hc/en-us/requests/647691

I have tried many things: wipe rvm, reinstall ruby, reinstall rubymine. 

Is there anyway you can assist me on this please?

Helen Z

0

Helen Zhang, this is a known issue, we are working on it. Please see temporary workaround: https://youtrack.jetbrains.com/issue/RUBY-17808#comment=27-1309279

0

请先登录再写评论。