How to hide all tool windows with shortcut key


The default key I think is CTRL+SHIFT+F12.

I have also tried to remap to other key combinations that are working for other actions.

I am using the latest EAP 14.0.x on Linux Mint 17.

The action works while using the mouse.

How do I bring this action back? thanks


Thanks for your quick reply. It is indeed what I have done, I have even changed the mapping suspecting a window manager shortcut that might override this.

However, whatever I choose as keymap, the key just doesn't react.

I have a very limited number of plugins and I don't think I have any third-party plugin except atlassian perhaps? I might try to remove it although just to test cause I don't think could do without.

Any feedback from a linux user, is this feature still working over there, and if so which wm you're using?



@Jona2jef does it help if you change the default shortcut?


You should just have to map it to the Main Menu > Window Active Tool Window > Hide All Too Windows action in the Keymap settings:


You may want to use the search by short cut button search-by-shortcut.png to make sure that CTRL+SHIFT+F12 is not also mapped to something else. If you still have issues, try disabling all third party plug-ins.


Hi everyone, I am a Zorin OS user, an Ubuntu-based Linux distribution. I too am facing the same problem. I am not able to use the short keys to hide all tool windows in IntelliJ IDEA. ANy help will be appreciated. Thank You


Sadly I don't use a modern desktop environment like GNOME or KDE which is very customisable, I use XFCE which is very old but snappy and repsonsive. Hence I was not able to change any shortcuts. Thank you for the suggestion sir.


@Jona2jef you could change a default shortcut in IDEA (File | Settings | Keymap).