generate constructor not working in 14

Running intellij 14.0.3

After upgrading to this version, when i click CMD+N and select generate constructor, i just get an empty constructor, nolonger any option to select which fields i want to include. This worked in 13, i haven't changed anything.

Haven't found the place to fix this, if it can be done. Pointers much appreciated.


This is working fine for me for 14.0.3 on Windows. There are no settings for this operation (in fact there is a feature request, IDEA-28206, to allow customization of generated setters/getters/constructors which just got implemented and is suppose to be in 14.1 when it comes out.) One possibility is that your caches are corrupt so IDEA is not "seeing" the fields and therefore does not list them. Try invalidating your caches via File/Application > Invalidate Caches and then restart IDEA. Let it re-index your project and then give it a try.



Yeah, i do not get that dialog anylonger. I got in 13, not in 14. Running on Mac OSX.

I tried the invalidate caches/restart thing as per you suggestion, but nothing changed unfortunately.