Maven import fails silently

Using 7684 I tried to create a project based on a pom.xml (Apache Trinidad).
When creating the project I selected "Import Project from external Model", then "Maven", selected the root folder, then left all default settings on.

After the wizard finishes, nothing happens at all (still see the Idea welcome screen).
I noticed that Idea had created "trinidad.ipr" and "trinidad.iws" in the root dir (no trinidad.iml).

I tried to open the ipr directly and Idea hid the welcome screen, but only to display an error message in the "Maven Importert Output" toolwindow:
Error:The project was imported with previous Maven Plugin version. Please reimport it in order to make it work properly.


Any quick help on this? I need to make some patches to the source code.
I don't have much hope of setting up the project manually and working with a plain text editor just won't do it.


Please check the log file for the exception that looks something like
at org.jetbrains.idea.maven.project.MavenToIdeaModuleConfigurator.findModuleFor(
at org.jetbrains.idea.maven.project.MavenToIdeaModuleConfigurator.configDependencies(
at org.jetbrains.idea.maven.project.MavenToIdeaModuleConfigurator.configModule(

If you find such - try using the previous release or wait for the upcoming one (that should be available today).


Previous release of what? IntelliJ, Maven, Plugin?

Upcoming release of what?



We are releasing 7.0.3 and you will be able to download it in a day or two.
Please try it.