TypeScript support in maven child project seems way worse in 12.1.x than 12.0.x?

I tried out 12.1.2 (IU-129.354) after being on 12.0.1 for a while and reopened my maven project which uses lots of TypeScript files and most of them are full of lots of red errors where it fails to find defintions, types, functions & properties - when this worked fine in 12.0.1.

Is there any clever tricks to get 12.1.x to work nicely again?

e.g. here's the project I re-opened:

its a multi-project maven build; this child project has all the TypeScript

all the typescript definition files are here:

and the modules and source files here:

is there some way to setup what the source paths are that TypeScript should use? I tried adding either d.ts and webapps/app or webapps as Source folders in the project structure (and tried on the Web config too) with no joy.


Hi, James.
Please take a look at IDEA-104757. Couldn't this be the issue?



I took a look at the issue; its hard to say to be honest - but its encouraging to hear I'm not the only one with JS/TS issues in 12.1.x. In my case all the TypeScript code lives inside a single maven project which is a WAR (its just there's other maven modules). I'll watch those issues and see if anything changes; meanwhile 12.0.x is pretty good :)