Managment port configuration not found



I am using  InetlliJ 11.1.3 Ultimate edition.
All my configuration seems okey as far as i can see, but when i run jboss 7.1.1 Final inside intelliJ i got "Error : Managment port configuration not found". anybody?
I am attaching screen shot below.
Appriciate your help :-).


@Richard Achmatowicz

This had been fixed as part of WildFly support ( which is available since IDEA 14.1.
Please try our most recent EAP for IDEA 17.1 (the public preview is available at, it should support your version of JBoss out of the box. 
The 13.x versions are not supported for a long time already. It would be not possible to port the fix there.






Management port of JBoss 7 is configured in the file <JBoss home>/standalone/configuration/standalone.xml
Default configuration looks like:
    <socket-binding-group name="standard-sockets"
        <socket-binding name="management-native"

Can you please check the following:
- the file exists in your environment
- IDEA has enough rights to access the file
- @port of socket-binding[@name='management-native'] has a valid value.

If the above looks fine, you may create a new YouTrack and attach your standalone.xml there (consider "visible only for IDEA developers" option),
and I'll check other possible issues.



Hi Michael!

Thanks for reply!
Yes all the port values seems right. Here comes a  tag from my standalone.xml.

<socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
        <socket-binding name="management-native" interface="management" port="${}"/>
        <socket-binding name="management-http" interface="management" port="${}"/>
        <socket-binding name="management-https" interface="management" port="${}"/>
        <socket-binding name="ajp" port="8009"/>
        <socket-binding name="http" port="8080"/>
        <socket-binding name="https" port="8443"/>
        <socket-binding name="osgi-http" interface="management" port="8090"/>
        <socket-binding name="remoting" port="4447"/>
        <socket-binding name="txn-recovery-environment" port="4712"/>
        <socket-binding name="txn-status-manager" port="4713"/>
        <socket-binding name="messaging" port="5445"/>
        <outbound-socket-binding name="mail-smtp">
            <remote-destination host="" port="25"/>


This case is solved.
I had had old deploy in memory which did that got this Error : ............... :




I'm using IDEA 13.1.7 Ultimate and am still seeing this frustrating issue with the above mentioned error: "ERROR: Native management port configuration not found." The JBoss Development plugin version I am using is 1.0.

1. Are you saying that the plugin's management port configuration requirement can only be satisfied by having the standalone.xml file in the location described above and a named socket binding called "management-native" with some port value specified? ?

2. Newer releases of wildfly do not include a management-native management interface in standalone.xml any longer....

3. Out of curiosity, does the plugin connect to the server via the management interface itself, for say, deploying applications?

I have a server configuration which meets the above criteria (Inless i'm doing something really stupid) and yet I still get the error. Which means I have to start servers and deploy applications outside of IntelliJ which is not fun. I really wish I could get this issue fixed up.





Hi Michael

Installed IntelliJ 2016.3, works as expected, and then some. Thank you so much for your help.



I know this is an old thread, but there's scant information about it out there, and this is the closest thing I've found. 


I'm using IDEA 2019.1 with the default JBoss integration plugin, and I'm getting this error when trying to configure a JBoss 7.1.1Final server. My standalone.xml looks exactly like Anil's above. I've tried messing with the syntax of the socket-binding tags to just set the port without the option, but no luck. 


Can someone please point me in the right direction? Thanks!


@Paul Springer My comment from 2012 still holds:

> If the above looks fine, you may create a new YouTrack and attach your standalone.xml there (consider "visible only for IDEA developers" option), 
and I'll check other possible issues






So, that bug appears to have been deleted. 216400 and 216402 exist, but the one's gone. Should I take that as a hint?



@Paul Springer the IDEA-216401 request at creation time was made visible to IntelliJ IDEA developers and to uvulabob login (the creator of the issue). So you should be able to see it when logged by uvulabob. Is there a problem to view it?


@Paul Springer, here is the copy of my comment from IDEA-216401: 


I can't reproduce with Jboss AS 7.1.1.Final and provided standalone.xml.redacted, renamed into standalone.xml and placed at jboss-as-7.1.1.Final/standalone/configuration/standalone.xml.

I tried with both IDEA 2019.1 and upcoming IDEA 2019.2, and for me, both versions correctly find 9999 as a value for management-native port.

The value comes from line 397 of the attached .redacted file:
<socket-binding name="management-native" interface="management" port="${}"/>, 

please re-check that your actual standalone.xml has this line exactly as in the `redacted` version.

If the above does not help, please also provide complete .idea folder from your project to investigate the run configuration data.