Buttons don't update in Beta or 5594?

Am I the only one seeing this? Buttons never update for me in either beta1 or the new 5594 build. It makes the IDE almost unusable.

- When a Run configuration quits, the Stop button is still clickable, but the Run button is not.
- The Navigate Forward button in the toolbar is never enabled, I can only go back.
- Choosing a run configuration from the menu does not make it displayed as the current run configuration, yet clicking Run does run the configuration I selected.

Is it just me? Did I do something wrong?

0

Keith Lea wrote:

Am I the only one seeing this? Buttons never update for me in either beta1 or the new 5594 build. It makes the IDE almost unusable.

- When a Run configuration quits, the Stop button is still clickable, but the Run button is not.
- The Navigate Forward button in the toolbar is never enabled, I can only go back.
- Choosing a run configuration from the menu does not make it displayed as the current run configuration, yet clicking Run does run the configuration I selected.

Is it just me? Did I do something wrong?


Something like this has happened to me with IDEA 4.5 in the following
condition:
While IDEA was running a configuration, because of a test procedure of
an application I had to set the system date/time back in the past. At
that moment it was not possible any more to change the Run
configuration, also other parts of IDEA behave strange. When the date
was reset to normal, everything went fine again.
Do you think these conditions may apply to your case also?

0

Keith Lea wrote:

Is it just me? Did I do something wrong?


I've seen similar behavior during plugin-development when IDEA didn't seem to call
update() on my AnAction implementations. However, I have no idea what the reason was and
could not reproduce the effect again.

Sascha

0

No, the date is fine, so I don't think this is the issue. Should I infer from your message that this isn't happening to you with the current build of Demetra?

0

Hello Keith,

That might be the case if IDEA frame is not focused. AnActions don't get
their called in this case.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

No, the date is fine, so I don't think this is the issue. Should I
infer from your message that this isn't happening to you with the
current build of Demetra?



0

No, that's not the issue, I'm definitely working in the IDE, the frame is focused.

0

I found a way to reproduce it. Just create a ChooseByNameContributor that throws an exception for CtrlAltShiftN. Press CASN and type a character. Now no toolbar buttons will be updated until you restart IDEA.

0

Hello Keith,

KL> I found a way to reproduce it. Just create a ChooseByNameContributor
KL> that throws an exception for CtrlAltShiftN. Press CASN and
KL> type a character. Now no toolbar buttons will be updated until you
KL> restart IDEA.

Could you please file a JIRA issue for this?

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0

请先登录再写评论。