Mac OS X Minimize issue?

Ok, I've just recently switched back to OS X... YAY... however working with IDEA has been an interesting experience. I'd heard about the font for the blind issue and indeed the default font is pretty dang big. There is a really annoying issue however, and wanted to know if there was a workaround or something I'm doing wrong before I file the bug. With IDEA 4.0.3, if I minimize IDEA, then maximize it, the 3 function buttons at the top left of the screen just all come on, and there is no way to minimize IDEA anymore at that point. That's pretty nasty. Anyway to shake that off?


P.S. IDEA does look pretty slick on OS X, but I think that's partly because of all the work Apple puts into making their Java interface look so dang native.


check out bug

That fixed it for me.

Not completely though. After a while I found it reverted to the same behavior. I have not worked out what makes it fall back to that behavior, if it does so regularly or if that was another program that caused the lapse.