915-Unusable: Can't even create project from scratch because of Local VCS issues

Hi !
I can't even create a new project with 915,
because of exceptions that seem to be related to LocalVCS.
BTW, i've been using IDEA EAPs for quite a while now, and I never managed to switch LocalVCS off, although the option to do so is available in the project properties...

Here is my usage pattern:
(NOTE: IDEA is not installed on my windowsXP box, no registry entry hanging around, no settings files left on my drives)

- I install IDEA 915 following the usual steps, I choose to store the settings and system files in my home directory
- When I first start IDEA, I'm first asked to create a project, and I do so: Create+Choose JDK, Choose my project dir, and the source dir (./src/ dir under the project dir)
- IDEA displays a progress bar and soon after I get:

at com.intellij.localVcs.impl.cc.]]>(cc.java:56)
at com.intellij.localVcs.impl.cc.getByteLength(cc.java:32)
at com.intellij.localVcs.impl.cj.b(cj.java:4)
at com.intellij.openapi.vfs.a.b.bi.getLength(bi.java:181)
at com.intellij.psi.impl.f.a.a.i.a(i.java:6)
at com.intellij.psi.impl.f.a.a.h.a(h.java:26)
at com.intellij.psi.impl.f.a.a.u.a(u.java:14)
at com.intellij.psi.impl.f.a.a.r.a(r.java:18)
at com.intellij.psi.impl.f.a.a.q.a(q.java:71)
at com.intellij.ide.f.d.a(d.java:27)
at com.intellij.ide.f.d.a(d.java:30)
at com.intellij.ide.f.a.a.run(a.java:5)
at com.intellij.openapi.application.b.d.runReadAction(d.java:24)
at com.intellij.ide.f.a.b.b(b.java:15)
at com.intellij.openapi.project.b.r.run(r.java:3)
at com.intellij.progress.c.a(c.java:52)
at com.intellij.openapi.project.b.q.run(q.java:3)
at java.lang.Thread.run(Unknown Source)

- I then close the exception message dialog, and I'm back to the main window, with no sub-windows in it: the project seems to be open (as I can close it using the command from the menu), but there is no GUI workspace...

- When I close the project, I get lots of:

2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl -
2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl - IntelliJ IDEA (Aurora) Build #915
2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl - JDK: 1.4.2
2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl - VM: Java HotSpot(TM) Client VM
2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl - Vendor: Sun Microsystems Inc.
2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl - OS: Windows XP
2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl - Last Action:
2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl - Current Command: Exit
2003-09-03 13:47:38,323 ERROR - ellij.project.impl.ProjectImpl -
java.lang.IllegalArgumentException: window with id="Structure" isn't registered
at com.intellij.openapi.wm.impl.ct.unregisterToolWindow(ct.java:464)
at com.intellij.ide.g.a.u.projectClosed(u.java:17)
at com.intellij.openapi.project.b.d.d(d.java:161)
at com.intellij.openapi.project.b.d.c(d.java:169)
at com.intellij.openapi.project.b.k.projectClosed(k.java:7)
at com.intellij.openapi.project.b.l.projectClosed(l.java:0)
at com.intellij.openapi.project.b.w.j(w.java:187)
at com.intellij.openapi.project.b.w.b(w.java:81)
at com.intellij.openapi.application.b.b.run(b.java:4)
at com.intellij.openapi.command.b.b.executeCommand(b.java:8)
at com.intellij.openapi.application.b.d.g(d.java:39)
at com.intellij.openapi.application.b.d.exit(d.java:31)
at com.intellij.openapi.wm.impl.g.windowClosing(g.java:0)
at java.awt.Window.processWindowEvent(Unknown Source)
at javax.swing.JFrame.processWindowEvent(Unknown Source)
at java.awt.Window.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.intellij.ide.s.a(s.java:61)
at com.intellij.ide.s.dispatchEvent(s.java:36)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Which I think is normal as IDEA tries to close the GUI

I tried to set the "use local VCS" option to off but it never worked (still the same problem).

I tried deleting the caches and other stuff in the IDEA 'system' dir but it never changed anything...

Basically, I can't even create a small project from scratch with 915.

I tried to use my old ipr files (using the 'open' command), but it never worked either (same sort of Local VCS exceptions)

When are we going to be able to switch this option off for good. I don't need localVCS, I don't want IDEA's 'system/vcs' folder to get filled with useless files...

Thank anyway for your consistant great work, and thanks for listening.



BTW, I've just tried 908 and it works fine


I've just installed 915 over the 908 previous install (with which I've just created and run my project), and it now works. (915 install kept all my 908 settings and caches, and the project can be compiled and run without exceptions)

...Strange that 915 can't start the project from scratch when it can handle the project if it has been created with 908...



dan wrote:

I can't even create a new project with 915,
because of exceptions that seem to be related to LocalVCS.

Looks like a bug, report it in the Tracker.


Gordon Tyler (Software Developer)
Quest Software <http://java.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: 416-643-4846 | Fax: 416-594-1919