[Windows 10] Blurry fonts only on external monitor


I'm in the process of moving from dual-screen desktop to laptop & external screen, and thanks to Windows 10 I'm having great difficulties with display scaling across various apps, but especially PHPStorm (10.0.2) with monitors of different resolutions / densities.

The main display is a MBP running Windows 10 and is 2560 x 1600 @ 175%, with the external monitor 1920 x 1080 @ 100%.

  • When PS is on the laptop monitor, it looks pin sharp (but in reality is too small to use for coding)
  • Move it to the external monitor, and it goes blurry. Not just the IDE text, but all labels.
  • If I disable display scaling then it looks pin sharp on both monitors, but all text is HUGE on the external monitor

I've also tried various options such as:

  • Togglng the override for Default Fonts in Settings > Appearance
  • Making the external monitor the main monitor (which has worked in the past for other apps)
  • Trying to open PHPStorm on one monitor first (no effect)

Whatever I try seems to be a tradeoff - one will look fine but the other will look awful.

Is there a solution to this? I'm about to throw the laptop out the window and go back to my desktop!



Thanks, I added my thoughts there.

Although JetBrains will ultimately be responsible for making this work, very, very few of my Windows apps seem to work on a mixed DPI screen setup. It's extremely disheartening!

FWIW, anyone else reading this - the setup I have found DOES work for me is to disable my laptop screen and run TWO 1920x1080 screens, that way there's no mix of DPIs to f*** everything up and it's like working on a desktop.

Meanwhile, JetBrains, many developers would be very grateful if you would please still attend to this issue!


I am having the same problem with WebStorm and it drives me crazyyyyy.

I am using Surface pro 4 (2736*1824 200% scaling) and 2 external monitors with 1920*1200 100%.

it shows pretty good on the surface screen but blurry on the external monitors.



It looks I managed to fix it in Windows 10.

Go to the shortcut of IntelliJ > Right click > Properties > Compatibility tab.

The Settings section shows a checkbox "Disable display scaling on high DPI settings". Check or activate it.

There you go. This fixed it for me.


I have same problem that @Ning and @Dave.

@Zeroshcr if I check "Disable display scaling" the IntelliJ in the external monitor (1920x1080) looks huge :(

Any idea?

Thanks in advance.


Currently, there's nothing much you can do about that, unfortunately. The issue posted by Elena is the key - please vote if you haven't done this yet.


For what it's worth, intellij will look sharp on the primary monitor active at the time of windows sign-in (on windows 10). So, you can get it to look sharp on any monitor, but you need to sign out, use windows+P to change which monitor is the active one, and then sign in again. Additionally, it may be necessary to switch font sizes to match the screen's dpi. It's a pain, but a good enough workaround in my case.


I'm having the same issue, but only when using the version 15 of any IDEA's products. Using the version 14 the font is crystal clear. I'm using Windows 10 in a external monitor 1920x1080, which I selected as my main monitor (my laptop monitor is 2160 x 1440).

You can see the difference between Intellij 14 and PyCharm 15 here: http://i.imgur.com/qTXOls2.png

Does anyone have a fix for this? I've selected the main monitor as my external monitor but the problem continues.


Miguel, that's antialiasing, you can disable it in Settings | Appearance & Behavior | Appearance.


The problem is that the fonts without antialiasing look very bad as well. My theory is that there's something that was added from version 14 to 15 in JetBrain's products that make the fonts look horrible in my monitor with antialiasing.

Is there anyone with this problem that knows how to solve it?

EDIT 1: I suspect this might be related to font rendering in Java. I found this (https://wiki.archlinux.org/index.php/Java_Runtime_Environment_fonts), and I started changing the "Dawt.useSystemAAFontSettings" in the vmoptions inside the bin folder.

However, I noticed that only the font in the Intellij's pop-ups was changing. Check here: http://imgur.com/a/OL2kF

I believe these configurations are only affecting the pop-ups and not the main UI. I also believe Java's font rendering allows a "second Subpixel" antialiasing which should appear in the Appearance > Appearence & Behavior menu, which is the one that I obtain with:


Could anyone give me any feedback on this?


I'm the OP, and you know what solved it for me?

Switching to Mac.

It was a long and painful process, but I'm finally at peace with my decision and no more blurry fonts 😂


Zeroshcr 's answer solved it for me too, although the checkbox label has changed slightly, and I had to select "System (enhanced)":


Zeroshcr 's answer solved it for me too, although the checkbox label has changed slightly, and I had to select "System". My Notebooks has a HDPI display, my external monitors do not.


Here is how to fix Blurry Font Problem In Windows 10

Right-click on the shortcut of the app you’re having an issue with.

Select Properties.

Select the Compatibility tab

Enable Disable display scaling on high DPI settings

3 most effective way to fix the problem is by using the XPExplorer – Windows 10 DPI Fix which is available for free.

1 – Launch the XPExplorer – Windows 10 DPI Fix

2 – checks for Use Windows 8.1 Scaling

3 – choose your scaling level .

Source:- http://merabheja.com/fix-blurry-font-problem-in-windows-10/


I just updated pycharm and I'm back to square one.

Before, I had checked to "Disable display scaling on high DPI settings" in Windows, but then the font became tiny. So I added `-Dsun.java2d.uiScale.enabled=false` to the VM options based on this article, which also fixed the size issue for me.

Today, pycharm updated and all of a sudden the VM option did nothing and the everything became tiny again. So I do disable the "Disable display scaling on high DPI settings", but now my fonts are very blurry looking and not sharp on my second monitor.

My main monitor is 4k, while the external is not.


My setup is that I have a laptop attached to two external monitors.  I closed the lid and had it so as long as the laptop was connected to power it would still output to the external monitors.  I noticed that WebStorm was fuzzy on one of the monitors.

Joeri's answer above fixed it for me.  I just logged out while the laptop lid was closed but still connected to the two external monitors, logged in, and restarted WebStorm. Beautiful now.


Definitely experiencing the same issue as is stated above within Windows 10.  My new laptop has 4K resolution, but my external monitor doesn't.  The above comments pointed me in the correct direction, but did not fully resolve my issue so that I could correctly view the my IDE correctly on both the external monitor AND the laptop screen.

The following steps resolved the issue:

  1. From within Windows, right mouse click on the Intellij short-cut icon (or Android Studio icon).
  2. Select Properties
  3. Select the Compatibility tab
  4. Within the Settings section, select the Override high DPI scaling behavior checkbox
  5. From the Scaling performed by: drop down, select System

Hope this helps others.


I've got a 1920x1080 laptop screen scaled to 125% and a larger 1920x1080 24" screen scaled at 100%, connected via HDMI on Windows 10 Enterprise.

The mentioned solutions only work partially. 

By default, IntelliJ looks crisp on the laptop screen and blurry on the larger monitor.

This solution works only partially. It becomes crisp on the monitor, but blurry on the laptop screen! So if I am working on my laptop I have to change the compatibility property of the shortcut again.

This solution with System (Enhanced) does not work for me. It displays crisp on the monitor, but then on the laptop it just breaks down. The GUI becomes all corrupted, not rendering properly, with buttons and panes misplaced.

I know this is a general Microsoft issue, even Office applications are suffering from this in certain cases. I know Chrome and Visual Studio Code don't suffer from it though. So there must be something the software could do. 


Issue seems to be fixed in the current version. Tested with JetBrains PhpStorm 2018.3.5 and it didn't work on an older version of 2017 I've had installed before.


For me helped changing the display Refresh rate to 60,011 Hz from 29,970Hz in Advanced display settings