Problem with Error: "Cannot start process, the working directory does not exist."


Hi there.

When I move a whole project from one computer to another, and I try to start the project in IDEA on the other computer, the following error occured when I want to start my unit-tests or want to start my application itself: "Cannot start process, the working directory does not exist."

There's no context for me to put this message in. I checked all my settings and everything seems to be allright. What have I done wrong?

Regards, Bernd



Check the "Working Directory" field in the Run panel (Maj+F10)



Horribly terse answer, daniel. That doesn't work. Nice try.



I had this problem as well, and I want to elaborate on Daniel's answer. This worked for me:

1. Click the drop-down menu with the name of the test in the upper right corner of IntelliJ and click "Edit Configurations".

2. Go to the box that says "Working directory" and delete the contents so that there is no text there.

I hope it works for you too. 


Glorious, that worked !!! Thanks for your comment....


Awesome odainanna, works like a charm! Thanks.


Thanks odainanna. It worked


This worked for me as well. Thanks


It worked!!!!!!!! Thanks odainanna !


Not worked for me. My "working directory' also blank. But still shows an error. What should i do?


Great work works!!!


Doesn't work. 

I had to delete the .idea configuration directory to fix this.


Thanks @daniel it's working fine for me.


encontre esta solucion:

1.-ve a 'Run'

2.-luego a 'edit configurations' 

3.- click en 'working directory' luego seleccionar la carpeta donde se encuantra todos tus proyecto.

dato: " si no funciona, prueba seleccionando especificamente tu proyecto.". Saludos!!!


Concept: You need to configure your working directory to the location where your file is placed.


  1. Click the box placed on the left side of the green run button. 
  2. Click on 'Edit Configurations...' 

  3. In the new window, go to the box saying 'Working Directory' and put the path where your project/file is present.
  4. Click on Apply and then OK
  5. The most important step: Thank Me 😀😀

The previous solution didn't work for me but I found one :

1. > File

2. >> Reload CMake Project

That creates the cmake-build-debug file that was missing.


If you face this problem running Python console in Django project, go to Project Structure and check the following:

  1. Modules - maybe there are orphan modules removed from filesystem.
  2. Facets - check each Django facet for path collisions or other issues. Try to remove all facets except the main one.

I was facing the same problem with a quarkus project loaded in IntelliJ; had to rename some module directories which broke the run configuration. The message was the one in the current thread; While quarkus has no working directory in the Run Configuration option, one might try to change the value of the workingDirPath in workspace.xml. Such as:

<option name="workingDirPath" value="$PROJECT_DIR$/modules/[the physical name of the folder]" />

Hopefully nothing is broken in Idea by this and for my case this worked.


In my case, the directory was inside a Google Drive folder mounted in Windows using the Google Drive desktop app, and the project directory path had a space "/My Drive/".

Moving the project directory outside Google Drive and with a spaces-free path fixed the issue.