Selection/scroll bug?

Is it me or is there a bug that drops the text selection when one end of it is outside the editor window and you scroll up or down?  For example if you use Cmd-W to select both ends of a curly brace delimited code block, when you scroll down to see the other end, the selection disappears as soon as you start scrolling.

I'm using PhpStorm 1.0.1 Build #PS-95.315 on a Mac running Mac OS X 10.6.4 on a Mac mini.



We can't reproduce the problem. Note that a lot of team members use Mac OS X and haven't noticed this.


I am definitely seeing this issue too - pressing shift and up/down arrow to expand a selection drops the selection the moment the editor begins to scroll.

I see this bug in PyCharm 2.5.2 and PHPStorm 4.0.2, running Mac OSX 10.7.4 on a Macbook Pro.


This is definitely happening to me too. As soon as the window scrolls my selection is lost.

I'm using PhpStorm 4.0.2 (build #PS-117.501, evaluation version) on JDK 1.6.0_33 and Mac OS X 10.7.4.



I'm using Win7 and PhpStorm 5.0.4. When I drag to move the scroll bar, the editor will jump back and select a line where the cursor was. That means if there is nothing selected, I have to move scroll bar twice to move to other part of a file. Do you know how to prevent the jumping back?



I just now witnessed the same issue. However, I discovered that if I ENABLE View->Toolbar and/or View->Navigation Bar, I'm able to continue selecting text, and the page will scroll by.  With BOTH of these toolbars disabled though, I"m only able to select the text that's visible on the screen.


What version do you use, and what is the OS?


I'm on version 2016.3 on OSX 10.11.6.  I thought that maybe the IdeaVIM plugin might be causing this, but I've disabled the plugin, and I still show the same symptoms.


I am running into this problem as well. Idea Version 2016.1.4 on OSX v10.12.4.

Is there any resolution to this? I might upgrade if I knew this problem was resolved.


I have the same issue, but only on my MacBookPro. on my MacPro (2.1) it works fine. Both Macs running with OS.X 10.11.6. Intellij Version 2016.2.5


I am also having the same problem. Problem continues until I restart my machine. This is really annoying.


Seeing this issue today on Linux (Ubuntu 18.0.4)


IDE version? Could you please reproduce this & record a screencast of it?


Apologies this was not the issue i saw i'll have a look and raise a new one.


What version of IDE do you have installed?


Alvarxx06, I am trying to gather any information from the screencast and fail. Since I can't see your mouse pointer, I can only guess what's going on.

The file appears to be broken between 0:02 and 0:07, and everything after 0:07 looks like you intentionally reset the selection by clicking elsewhere.

Do I miss something?


Same problem here (I think).

See attached screen recording.


  • I clicked on line 14.
  • then moved the cursor to the project file view on the left
  • note how the selection follows the mouse even though: I am not clicking any mouse buttons.
  • Same thing happens with the touchpad.
  • ie: the text selection feature is engaging even though none of the mouse buttons are selected!

Second issue, possibly related:

  • the right click mouse button does not bring up any popup.


  • Note this is Intellij Idea not PhpStorm
  • The version is the screencast is 191.6707.61 (2019.1.1).
  • Same problem occurs with at least: 2019.1.2 and 2019.1.3RC (latest)
  • ie: I downgraded from 2019.1.3RC to 1.2 to 1.1 to try to see what changed.

Operating system: Ubuntu 19.04 on a Dell  9570 with 32GB RAM




Are you using touchpad for this or a usual mouse? 


@Dmitry: it happens with both touchpad and mouse.

Problem resolves after rebooting the machine, the happens again after a few minutes.

Not sure what triggers it, but after a few minutes of use I need to reboot to get a usable editor.

The other thing that happens is that when the text is in that selected state, if I try to scroll the editor, then the whole text sort of jumps, and prevents scrolling.


David Moshal, please check if disabling Help | Find Action | Registry | suppress.focus.stealing helps.
If it does not, please submit the issue to our issue tracker attaching the logs bundle (Help | Compress Logs) after you restart the IDE and reproduce the issue once again. Thank you!


I spent forever trying to track down a behavior that looked just like this on my MAC.  Even tried to dump Pycharm I was so annoyed with it.  Finally discovered what it was.

I have a logitech mouse where the mouse wheel can technically be pressed to be a middle mouse click.  I don't know if the mouse is getting old but using the wheel would cause a middle press every once in a while.  Once it did Pycharm did exactly this behavior in the video.  What made it worse is Pycharm seems to like to remember the selection state on documents.  Middle mouse event: selection chaos even when the editor didn't have focus.  Solution: Went to 3rd party and disabled middle mouse at the OS level.  Haven't seen this behavior since.


Could be a coincidence that it looks just like what you posted in the video.


I do have a logitech with a mouse wheel, the M570.

HOWEVER: The problem happens with the laptop's touchpad too, even when the logitech is turned off and the dongle removed.

The laptop is a Dell XPS 9570 hexacore with 32GB RAM.

The distribution is Ubuntu 19.04 with these hardware drivers:

I haven't seen it on other programs on that machine, nor has anyone submitted an issue on the above hardware patch.

I have noticed that around the same time I loose the right-click menu on Chrome.

Both problems resolves on reboot, then at some point are re-triggered.

It does not occur on my desktop, which has Ubuntu 18.04. (the laptop has 19.04)

The issue has resolved lately, so I suspect that either one of these has fixed it:

a) An Ubuntu 19.04 update (btw, I suspect that this is the likely suspect)

b) An Idea update. I'm now using 2019.1.3 with automatic updates set to Release only (ie: not Release and EAP).

My plan if this recurs is to look both in the Ubuntu logs and the Idea logs.



Facing the same issue.

I click on any line in editor and then take cursor out of editor area. If I just scroll it outside, the selection in editor also scrolls.

OS : Ubuntu 18.04.2 LTS

Laptop model : Dell Latitude E7470


Here is the video -


PS - I tried with latest community edition as well as with EAP edition. It's happening on both.


One more observation : this seems to be a bug with specific machines. I had an older version of Idea community. I worked on it with my previous machine and it was fine. When I opened that version (hoping it was fine, so it should work), even I faced similar problem there. 


Please comment & share details about your environment at


I am having the same problem as David Moshal.

Ubuntu 19.04, Dell XPS 9380, PhpStorm 2019.1.3


Please comment & share details about your environment at

As advised there - try touching the screen to see if it helps temporary



I have the same problem. very often. 


I got same problem. Using PHPStorm 2018.3 on Ubuntu 18, Dell Inspiron 5379 i7. It happens with touch pad. Touching screen is temporary solving that. Is there permanent solution?