ScalaTest throwing IllegalArgumentException

I have been trying to run scalatest in intellij and I keep running into an IllegalArgumentException stating that -r has been deprecated. 

You can find the stack trace at the follow gist.

I am able to run this with sbt (since I include scala test a dependency in my project).

But when I try to use intellij's builtin scalatest it keeps throwing the error.

The test file I am "running" can be found here.

Am I doing something wrong?

What is the best way to resolve this issue.

评论操作 固定链接

I've created a ticket https://youtrack.jetbrains.com/issue/SCL-10607 for further tracking of this issue.

Having this information I couldn't reproduce the error. Is it possible for you to try it on latest version of Scala Plugin (2016.2.1) and IDEA 2016.2 ? Or at least, let us know what version of IDEA and Plugin do you use.

* You may reply right in Youtrack ticket in case you have an access.

0
评论操作 固定链接

Hi Anton, thank you for creating the ticket.

I have responded on the ticket as well.

Upgrading the version fixed the issue for me.

 

 

0

请先登录再写评论。